WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Admin Login comes up blank (white, no code); Can’t Login. Blog working.

[Resolved] Admin Login comes up blank (white, no code); Can’t Login. Blog working.

Viewing 8 replies - 1 through 8 (of 8 total)
  • rename your theme folder, thus activating default theme
    if a theme error this will let you log in

    if neither of these work, try these memory options

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');
    
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    Awesome, thanks for the quick reply… I’ll give these a try and see how things work out.

    – Matt

    Here’s how it worked:

    I changed the folder name for my theme (suffusion), and there was no change to the admin login page, but the rest of the blog also picked up the same problem (ie, no longer worked… blank white only). So I changed it back.

    I opened my php.ini and found that my memory limit was set to 32, so I changed it to 64 and re-upped it.

    Still nothing, unfortunately. That seemed like it had so much potential, too…

    Any other ideas? THANKS again for all your help!

    – Matt

    Don’t know why it didn’t occur to me earlier, but I checked the error_log and found quite a few new entries for today… dozens, hundreds maybe. They’re all different, but are generally like this:

    [01-Apr-2010 15:52:47] PHP Warning: Zend Optimizer for PHP 5.2.x cannot be found (expected at ‘/usr/local/Zend/lib/Optimizer-2.5.10/php-5.2.x/ZendOptimizer.so’) – try reinstalling the Zend Optimizer in Unknown on line 0

    However, I’m seeing this same general error as far back as March 12, and I’ve had normal functionality until today. Think this might be related? I don’t really know what Zend is (my site is hosted on BlueHost, so I didn’t install the php or any of the related software), so although it seems to be some kind of problem, I’m not sure that it’s THIS problem.

    – Matthew

    !!!!!!!! Fixed my huuuge problem
    http://wordpress.org/support/topic/382418?replies=16

    thanks to your post
    Just hit some enter at the bottom of the functions template.
    I don?t now what I did!!

    Hi fkaf, glad to hear your blog is working again. Now, if I can just figure out what the problem is with mine…

    -Matt

    WTF?

    So, I looked at the most recent error in my error log, which said:

    [02-Apr-2010 00:23:12] PHP Warning: Cannot modify header information – headers already sent by (output started at /home4/goreorch/public_html/gorephoto2/blog/wp-config.php:152) […etc]

    So, I opened up my wp-config, and found that line 152 was a BLANK line at the end of the document. I deleted it, and that solved my problem.

    I have no idea how it got there, and now I guess I can only hope that it doesn’t happen again.

    – Matt

    Matt,
    I’ve experienced the exact same thing for the first time this a.m.

    I go to the login page, put in user and pass, just goes to blank page.

    Blog works fine otherwise (www.ethanbeute.com/wordpress).

    My problem: I have no technical skills at all. I don’t even know where to find my error log.

    Help?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Admin Login comes up blank (white, no code); Can’t Login. Blog working.’ is closed to new replies.