[resolved] admin login and pw linked for 2 sites after migration (5 posts)

  1. pheemcd
    Posted 2 years ago #

    Newbie alert. I'm pretty sure I know how I did this, I just don't know how to undo it.

    I was practicing a manual site migration by installing WP into a new folder on the same server, copying the 'old' wp-content files over to the 'new' wp-content folder and installing the php database on the server through the cpanel. It didn't look right so I started copying ALL the other files over into the new folder, including the wp-admin folder. Obviously a mistake, so now I want to just delete the new folder on the server but now my wp login and pw are the same for both sites (mysite and mysite/demo) and I'm afraid the sky will open up and my site will get struck by lightning (aka white screen of death) if I delete the new folder. Changing pw's doesn't work as it changes for both of them.

    I'm hoping nothing will happen to the 'old' site if I delete the 'new' one - am I stark raving mad?

  2. Diogo
    Posted 2 years ago #


    You probably used the same database and table prefix while installing WP in the /demo folder.

    Check the wp-config.php in both folders and se if the $table_prefix var is the same on both.

    In any case, deleting files will hardly mess with the database, but backing up everything is always a good measure.


  3. pheemcd
    Posted 2 years ago #

    Thanks for replying!

    Both wp-config.php files have the same thing (they are copies):

    $table_prefix = 'wp_';

    Is that creating the login problem? I have backed up the files, and I'm fine with deleting the new failed clone 'demo' folder, as long as I won't have a problem logging into the 'old' site after that. I think I'm no good at manual migration and I will need to find a good plugin to manage it for me.

  4. Diogo
    Posted 2 years ago #

    Yes, you are basically running the same blog at two different addresses. Deleting the files won't hurt your database, I'm pretty sure you can safely delete the failed clone folder.

    Manual migrations are, well, manual. It takes a little work, but they are not impossible. Practice a little more and you will be acing it in no time!

    Good luck!

  5. pheemcd
    Posted 2 years ago #

    I deleted the dreaded file and....everything's fine. Now back to practicing migration! Thank you very much for your help! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic