Support » Plugin: User Groups » Admin is "not allowed to manage these items"

Viewing 9 replies - 1 through 9 (of 9 total)
  • PS: it’s working fine in WP 4.3.1, so the issue is occurring with WP 4.4-beta.

    To fix this issue, in the function register_user_taxonomy() you have to add the show_ui-option to the register_taxonomy()-call and set it to true.

    Here is the code (user-groups.php):

    function register_user_taxonomy() {
        register_taxonomy(
            'user-group',
            'user',
            array(
                'public' => false,
                'labels' => array(
                    'name' => __( 'User Groups' ),
                    'singular_name' => __( 'Group' ),
                    'menu_name' => __( 'User Groups' ),
                    'search_items' => __( 'Search Groups' ),
                    'popular_items' => __( 'Popular Groups' ),
                    'all_items' => __( 'All User Groups' ),
                    'edit_item' => __( 'Edit User Group' ),
                    'update_item' => __( 'Update User Group' ),
                    'add_new_item' => __( 'Add New User Group' ),
                    'new_item_name' => __( 'New User Group Name' ),
                    'separate_items_with_commas' => __( 'Separate user groups with commas' ),
                    'add_or_remove_items' => __( 'Add or remove user groups' ),
                    'choose_from_most_used' => __( 'Choose from the most popular user groups' ),
                ),
                'rewrite' => false,
                'capabilities' => array(
                    'manage_terms' => 'edit_users', // Using 'edit_users' cap to keep this simple.
                    'edit_terms'   => 'edit_users',
                    'delete_terms' => 'edit_users',
                    'assign_terms' => 'read',
                ),
                'update_count_callback' => array(&$this, 'update_user_group_count'), // Use a custom function to update the count. If not working, use _update_post_term_count
                'show_ui' => true
            )
        );
    }

    I did exactly as said:

    I added ‘show_ui’ => true exactly as said.
    I also tried ‘show_ui-option’ => true, but this did not work either.

    function register_user_taxonomy() {
    register_taxonomy(
    ‘show_ui’ => true,
    ‘user-group’,
    ‘user’,
    array(
    ‘public’ => false,

    But is does not work, I get an error. Plugin not working. error on line 333. unexpected …..

    WordPress user are no programmers, I would appreciate a complete code or explanation. Thank you very much, in advance. And forgive me that I am just a user.

    Lisa, I can confirm that Asgaros information is correct, by adding 'show_ui' => true the problem is solved.

    Here’s a clearer way on how to add that line. I suggest to add it after line 314 (in the current version as of January 2016):

    The original code looks like this:

    array(
      'public' => false,
      'labels' => array(

    Add your new line after 'public' => false, like this:

    array(
      'public' => false,
      'show_ui' => true,
      'labels' => array(

    After that, you will be able to access the admin area.

    Kudos to you for taking a dive into PHP editing while being just a user 🙂

    Thank you very much, that did work right away. I really apreciatet this precise instruction.
    Cheers, lisa

    I was pulling my hair over this, thank you!

    Hi,

    Could we have these fixes in the official repo and a new release please? 🙂

    Is the development done on github? If so I would be happy to submit a PR if this would make the process smoother.

    I just used the exact instructions from Manuel Schmalstieg to fix my occurrence of this defect. Thank you very much!

    Plugin Author Zack Katz

    (@katzwebdesign)

    Thanks all—this has been updated in Version 1.3, just released!

    I also added a Github repo so future contributions can be made there: https://github.com/katzwebservices/User-Groups

    Thanks again.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Admin is "not allowed to manage these items"’ is closed to new replies.