Support » Plugin: Easy Photography Portfolio » Admin is broken

  • Resolved pointlessone

    (@pointlessone)


    Hi!

    I’m not quite sure what may be the root cause but here’s what I found. The New Portfolio Entry page doesn’t seem to include all JS it needs. Anything dynamic on that page doesn’t work. That includes tab switching in the widgets, media upload, visual editing, etc.

    Public part is OK. Old portfolio entries can be viewed and are functional.

    Some basic info:

    * WordPress 4.9.2
    * Easy Photography Portfolio 1.4.6

    Please advise. Don’t hesitate to ask if you need any additional info or want me to do anything to help you debug the issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The admin area is working for me on those versions. Can you open the developer console in your browser to see if it shows any issues?

    Are you using any caching plugins? Have you added any plugins recently that might have broken the admin area?

    No, I didn’t install any new plugins. Though, I updated plugins and WP recently. Portfolio worked earlier.

    Full list of plugins:

    • Contact Form 7
    • Easy Photography Portfolio
    • Events Made Easy
    • Google Analytics Dashboard for WP (GADWP)
    • WP Mail SMTP

    I don’t use any caching plugins but I don’t know if WP itself does any caching. If so how can I clear the caches?

    Console shows no errors.

    I can create a new (regular) post. There all scripts are loaded and seem to work properly.

    The new portfolio entry, however, seem to not load all the scripts. Notably, this request is made on the new post page, but not on new portfolio entry:

    [domain]/wordpress/wp-admin/load-scripts.php?c=1&load%5B%5D=hoverIntent,common,admin-bar,heartbeat,autosave,suggest,wp-ajax-response,jquery-color,wp-lists,jquery-ui-core,jquery-ui-widget,j&load%5B%5D=query-ui-mouse,jquery-ui-sortable,postbox,jquery-ui-position,jquery-ui-menu,wp-a11y,jquery-ui-autocomplete,tags-suggest,tags-box&load%5B%5D=,underscore,word-count,post,editor-expand,thickbox,shortcode,backbone,wp-util,wp-backbone,media-models,wp-plupload,wp-mediaeleme&load%5B%5D=nt,wp-api-request,media-views,media-editor,media-audiovideo,mce-view,imgareaselect,image-edit,svg-painter,wp-auth-check,editor,q&load%5B%5D=uicktags,wplink,media-upload,wp-embed&ver=4.9.2

    Which PHP version do you have? Can you view the source and paste the last 5-10 lines of the source code that you can see? For example:

    						<a class="screen-reader-shortcut" href="https://wordpress.org/support/wp-login.php?action=logout&_wpnonce=716021bc3a&redirect_to=https%3A%2F%2Fwordpress.org%2Fsupport%2Ftopic%2Fadmin-is-broken%2F%3Floggedout%3Dtrue">Log Out</a>
    					</div>
    
    		</body>
    </html>

    Also, try deactivating all other plugins except Easy Photography Portfolio – does that change anything? Which hosting provider are you using?

    • This reply was modified 2 years, 1 month ago by Colormelon.

    Oh, this is interesting. The page appears to be incomplete:

    
    <!-- Begin CMB2 Fields -->
    <input type="hidden" id="nonce_CMB2phpphort_post_after_meta" name="nonce_CMB2phpphort_post_after_meta" value="0be077eb0c" /><div class="cmb2-wrap form-table"><div id="cmb2-metabox-phort_post_after_meta" class="cmb2-metabox cmb-field-list"><div class="cmb-row cmb-type-file-list cmb2-id-phort-gallery" data-fieldtype="file_list">
    
    	<div class="cmb-td">
    

    I host it myself. I run PHP FPM 7.2.1 behind Nginx.

    Deactivating all other plugins have no effect on the issue.

    With debug output I’m getting the following:

    Fatal error: Declaration of CMB2_Type_File_List::render() must be compatible with CMB2_Type_Text::render($args = Array) in [webroot]/content/plugins/photography-portfolio/vendor/webdevstudios/cmb2/includes/types/CMB2_Type_File_List.php on line 13

    Hello, Justin Sternberg, lead developer of CMB2 here. This is because the version of CMB2 being used here is not compatible with PHP > 7.1. If CMB2 is bundled in this plugin, then the plugin author will need to update the bundled version to the latest version of CMB2 which contains the fix: https://github.com/CMB2/CMB2/releases/tag/v2.3.0

    As a temporary fix for your site, you should be able to install the actual CMB2 plugin and it will override the bundled version, fixing the issue: https://wordpress.org/plugins/cmb2/

    Another temporary fix would be to rollback to any version of PHP before 7.2.

    @jtsternberg Thank you!

    Plugin Author justnorris

    (@justnorris)

    Thank you @jtsternberg
    I’ll update Easy Photography Portfolio to version 1.4.7 in a few minutes with CMB v2.3.0

    👍 My pleasure.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Admin is broken’ is closed to new replies.