Support » Plugin: WordPress Captcha Plugin by Captcha Bank » Admin IP address blacklisted automatically in Captcha Bank

  • Resolved fcarothers

    (@fcarothers)


    My IP address is being added automatically to the Captcha Bank “blacklist IP address” list. After working in my WordPress admin account, my IP address is added to the blacklist and, upon logout, I receive the message:
    “Your IP Address xxx.xxx.xxx.xxx has been blocked by the Administrator for security purposes. Please contact the Website Administrator for more details.”

    (In above message I’ve replaced my IP address with x’s for security purposes.)

    Other plugins I have installed include Wordfence and Easy Updates Manager paid versions. Easy Updates Manager was just installed this morning, but it was also installed on other sites that are not experiencing this problem.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Solution found — This problem can be overcome by going to the Captcha Bank “Blockage Settings” and disabling the “Auto IP Block” setting.

    For some reason, Captcha Bank was counting failed “login” attempts when there were no failed login attempts. As a result of incorrectly counting login actions as failed login attempts, Captcha Bank was automatically blacklisting my IP address as soon as I logged out of WordPress.

    Whitelisting my IP address did not resolve this problem. Turning of the “Auto IP Block” option appears to have bypassed the problem since Captcha Bank is no longer counting what it thinks are failed login attempts.

    Serious bug in the software to count failed login attempts when there were no failed login attempts.

    Plugin Author Varun Sharma

    (@contact-banker)

    Hi,

    In order to solve your issue we need additional information.

    We would request you to contact us on our website.

    Thanks & Regards.

    Plugin Author Varun Sharma

    (@contact-banker)

    Hi,

    We haven’t heard back from you.

    That’s why we are closing the ticket.

    You may reach us via our contact form on our website.

    Thanks & Regards.

    papanin

    (@papanin)

    I have the following error: captcha-bank.php on line 686.
    version 4.0.35
    Auto IP Block is disabled

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.