Support » Installing WordPress » Admin interface serving blank page after upgrade

  • Hello –

    I’ve looked at many posts here but haven’t been able to glean an answer from them, so I apologize if this is redundant.

    I deleted/updated the files as the instructions directed. I ran the upgrade, and was told the upgrade was successful. I went to the login page, which had the new look. After clicking submit with my credentials, I’m brought to the /wp-admin/ directory. The page is blank. A quick look at the source and nothing is being served.

    I do not have access to error logs with my host.

    Any thoughts? Something with .htaccess maybe (which I can’t see in my FTP software WS_FTPpro)

    Thanks, Bill

Viewing 10 replies - 1 through 10 (of 10 total)
  • I’d first consider deleting the WordPress files, then reupload, per Steps 7 and 8 in Upgrading_WordPress_Extended.


    Thanks Michael –

    No luck though. I deleted and re-uploaded everything in steps 7 and 8. I did just find out I can get to the admin if I am approving a comment, but the admin dashboard is still blank.

    Any other ideas?

    Thanks for your time.

    I seem to be having the same problem here. We still haven’t seen any resolutions, though I’ve been looking for one.

    I recently had this same problem. Deactivated all the plugins. Deleted the necessary files. uploaded all the files – the blog was showing up fine – but going to wp-admin showed a blank page. could not hit upgrade.php (just a blank page). So I deleted the new files – uploaded the OLD ones – then I had no problem getting in to wp-admin. Tried it again – deleted the old files, uploaded the new ones – again, a blank screen. The most frustrating part about it is that I called the host provider and they said they weren’t seeing any errors come up – so no clue where to begin to look for a the problem.

    This seems very similar to except some people seem to be getting an error.

    There is a work around: login, see the blank/error page, go to any public post on the blog and hit the “edit” button which will direct you to the error-free admin.

    However, not a single serious clue about what is going on here…

    Ok, cornered it: I have looked at 3 installs, and the problem surfaced for 2 of them. The only “common” point of the 2 problematic ones is that they are using the Getk2 theme, and the Akismet plugin, on a hosting with php5.

    I switched to the classic theme and the problem has disappeared.

    So it seems that getk2 is interfering with the login procedure, for some obscure reason. Can anyone else confirm that changing to the classic theme removes the problem met with k2 ?

    In my case it was a custom theme and we were not using Akismet. I will try the trick with going directly to a post. Question, though – were you even able to RUN the upgrade? In my case I couldn’t even hit upgrade.php (so I would think trying to edit a post would send me to the “you need to run the upgrade” page…not the edit the post page…?)

    I may have discover a solution to this. I was faced with this issue and out of pure frustration, I finally deleted all of my plugins with the exception of the default ones included in the distribution package of WordPress, and found that I indeed had 1 that was not compatible with WordPress 2.5.1.

    The WP-SpamFree Plugin did not like the changes in 2.5.1 for some reason. If you have this plugin installed, try deactivating it, or deleting it and recheck your results. There may also be another in the group of installed plugins causing the issue.

    I am the author of the Gaboinked! Chipin Sidebar Widget for WordPress and can assure you that it is compatible with WordPress 2.5.1.

    So I have a question – (since I am STILL not able to upgrade that site to WP 2.5) according to the requirements page – it says PHP 4 is still ok – but I’m getting suspicious that maybe 2.5 now requires PHP 5? Does anyone know?

    I know I forced my hosting to php5, just to make sure (I have a vague souvenir that it wasn’t working when I had php4, but don’t quote me on that). Sorry not to be of any more help.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Admin interface serving blank page after upgrade’ is closed to new replies.