Support » Plugin: Centrora Security™ » admin email mapping not working

  • Resolved dormaj

    (@dormaj)


    I have OSE 2.2.1 installed and I cannot save any admin email config details. The USER: and EMAIL: fields do not populate and no matter what I enter I cannot save the linkage.

    Also, your notes in the ‘Installed Plugin’ page don’t make sense. I cannot find the Security link you reference:

    OSE Firewall Security – A WordPress Security Firewall created by ProWeb (Protect Website). It protects your WordPress-powered blog against attacks and hacking. The email alert / notification function is disabled by default, while it can be activated and configured in Settings -> OSE Firewall Security. Please go to your OSE Firewall Security configuration page.

    Version 2.2.1 | By ProWeb (Protect Website) | Visit plugin site

    Are email notifications on or off? And where is the setting?

    Thanks for your help.

    http://wordpress.org/plugins/ose-firewall/

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Helix.L

    (@prohelix)

    Hi dormaj

    We are investigating the issue, some websites have such problem, and we are checking where the problem is, will release a new version asap when we found the cause.

    Best wishes
    Helix
    [ Signature moderated. ]

    All my sites are on Godaddy and all have this problem since the core interface was changed/updated. I’ve been a long time advocate of OSE Firewall and this has stopped me dead in my tracks.

    Thanks for your help. I hope you find the fix soon.

    Plugin Author Helix.L

    (@prohelix)

    Hi dormaj

    We found that some servers do not use wp_capabilities in their meta tags in the user_meta table, so we change our codes to get the administrator list for these websites, please try 2.2.2 and see how it works, it should work fine now.

    Hope this helps. 🙂
    Best wishes
    Helix
    [ Signature seriously moderated. ]

    I’m working on a Host Gator WP (WP 3.6.1) hosting site, and a GoDaddy site, and I installed 2.2.2 and it does not work on either. So I upgraded to 2.2.3 and it still does not work. You took a great piece of code and it’s been broken ever since. Please get it together.

    i also can;t add admin email mapping there is no user i can linkage, how to function this?

    Plugin Author Kai

    (@prokai)

    Hi dormaj & ad4msan,

    We are working on these issue. To help us better investigate the issues, can you please do either the following:
    go to the link below, follow the steps inside,
    https://www.protect-website.com/using-firebug-report-bugs/

    OR

    go to our support center here,open a ticket and provide us a temporary WordPress Adminitrator account for us, so that we can check and resolve the issue asap.

    We really appreciate your contributions on these, which help us making a better OSE Firewall and provide best services to you. Thanks 🙂

    Cheers
    Kai
    [ Signature moderated. ]

    Thanks for answer kai, i have used firebug but there is no error when i try to linkage admin email mapping no user i can scrol or add but in the box below (email) i can scroll/ many option i can choose. can you fix it?

    Plugin Author Kai

    (@prokai)

    Hi ad4msan,

    one more steps for you, please provide us the meta_key value:
    1.) go to phpmyadmin
    2.) find this table: ‘wp_usermeta’
    3.) find the meta_value with value like this: a:1:{s:13:”administrator”;b:1;}
    4.) tell us the value of the meta_key in this row
    e.g. by default, WordPress’s meta_key is ‘wp_capabilities’ and its value is a:1:{s:13:”administrator”;b:1;}

    we are getting close to the solution, once you get us the meta_key value 🙂 Thanks for your help.

    Cheers
    Kai
    [ Signature moderated. ]

    in my phpmyadmin meta_value a:1:{s:13:”administrator”;s:1:”1″;}

    is it true?

    Plugin Author Helix.L

    (@prohelix)

    @ad4msan

    Yes, it is true, could you please tell us the meta_key for that row as well, so in phpmyadmin, the row with meta_value of a:1:{s:13:”administrator”;s:1:”1″;} usually has a meta_key with the value of ‘wp_capabilities’. However, some websites has some plugins changing this value to sth like ABCwpcapabilities, this causes the issue and which was fixed it in 2.2.2.

    Could you please show me the value for the meta_key for that row?

    Best wishes
    Helix
    [ Signature moderated. ]

    meta key: v1t4d4mcapabilities

    yes, i’m use plugin that rename the prefix of the database to prevent exploit my database, is there any solution for this? i don’t want to use default wordpress prefix which to risk for security

    Plugin Author Kai

    (@prokai)

    Hi ad4msan,

    We figured out the problem with it. Just be patient for our next update, that will fixed this issue. By the way, you don’t have to do anything about it, we will make OSE Firewall compatible with that plugin.

    Cheers
    Kai
    [ Signature moderated. ]

    Plugin Author Helix.L

    (@prohelix)

    @ad4msan

    We updated the codes in version 2.2.5, it should show the administrators in the list now, please try again. Hope it helps. 🙂

    Cheers
    Helix
    [ Signature moderated. ]

    Thanks for the update, another problem is can’t save linkage. user and email now have shown perfectly. but i can’t save the linkage. Anything solution for this?

    Just updated to 2.2.5. It shows the admin email in the drop down. But it does not populate the email address. That would be helpful. And the SAVE button does not work. Nothing happens when you click on it.

    Could you just use the default admin name and email (from Settings) as a default. And then people could delete it from the linkage if they don;t want it? I’d rather have that the nothing that I have right now.

    Thanks for you keeping at it.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘admin email mapping not working’ is closed to new replies.