Support » Plugin: MarketPress - WordPress eCommerce » Admin does not have access to Store page

  • Resolved barctic

    (@barctic)


    I just gave Marketpress another try and after installing, the administrator account did not have access to the Store page and could not create products. When trying to manually create product via [sites]/wp-admin/post-new.php?post_type=product as an admin it says “Cheatin’ eh? Sorry, you are not allowed to create posts as this user.”

    Also tried to change to slug to mp_product – didn’t fix.

    I gave editors all product permissions via store settings -> user capabilities then created an editor account. This account was able to add products and view the Store post page.

    This is a fresh install of WordPress, with only Marketpress installed (no other plugins). Default theme.

    Any reason why this would happen? Or at least, how can I add product editing capabilities back to the admin account?

Viewing 9 replies - 1 through 9 (of 9 total)
  • I’ve just installed Marketpress on a site I’ve had running for around a year now. Whilst I’ve been able to set up everything just fine, I skipped the Add Products section of the setup wizard with an intention of doing it later, but I can’t see the products tab at all. My user role is Admin. The User Capabilities section of MarketPress doesn’t allow me to assign “Admins” any capabilities, so I think I’m locked out unless I create an Editor account.

    Hey Marketpress, are there any updates on this? It seems to be very material to the functionality of the plugin.

    Agreed, we appreciate this is a free plugin but an update just to know you’re aware would be good 🙂

    Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hey guys,

    Sorry for delay here, we somehow missed this thread 🙁

    I did a test on my installation and I was unable to replicate this on old or new clean installation I’m afraid.

    Can you give me a bit more information about your setups, which version of PHP and WP you are running?
    Also, on which browser and OS you are testing this so I could check if it could be related to that?

    Cheers,
    Predrag

    Hi Predrag,

    I’m running PHP 5.5.0 on Ubuntu 14.04 LTS. My WordPress install is 4.8.2–en_GB

    Here’s a screenshot of my menu when logged in as an Admin:
    https://imgur.com/a/mDui2
    I can confirm that the menu appears correctly when logged in as an Editor.

    My market press version is 3.2.5

    Andy

    Just updated Marketpress to 3.2.7 and the same issue is still occurring.

    Hi Predrag,

    I am running PHP 5.6.3, on a local MAMP dev setup with the latest version of WP. Tried on Chome and FF. Like I said, tested with a fresh WP install, no other plugins and default theme.

    I have tried other configurations and same issue. Same screenshot as Andy, no option for admin to see/edit products.

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello @wormholer693,

    I’m checking this on my setup on Ubuntu with PHP 5.5 and latest MarketPress version and I’m not able to replicate issue.

    Can you enable debug.log and see if there are any errors. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
    define('WP_DEBUG', true);
    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

    I would need then to see content of the debug.log file – so please upload it to service like a Dropbox and paste link here.

    kind regards
    Kasia

    Plugin Author jdailey

    (@jdailey)

    Thank you for using MarketPress. I am going to close this topic for now. If you have created a debug log and would like us to assess the file, share it with us and we will reopen the thread.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Admin does not have access to Store page’ is closed to new replies.