Support » Fixing WordPress » Admin Dashboard Plugins.php page blank in WordPress 2.7

  • I cannot seem to bring up plugins.php when going to the plugins option in the admin dashboard.

    I could initially upon first installing WP, which I installed some plugins that may have caused conflicts to prevent things from working now. However, even reinstalling wordpress does not fix the issue of being unable to access the plugins. I can edit them, but not add or view what plugins are there.

    Viewing is possible if I relabel the plugins folder, but once properly labelled it does not work.
    I could initially view plugins, so my host (Free Hostia) can support wordpress properly.
    I’ve deleted the database and recreated it with a fresh install, which still does not work. Even created different database names.
    I’ve checked the link in both Mozilla Firefox and Google Chrome.

    I do get this error when editing plugins:
    “Wrong datatype for second argument in …/blog/wp-admin/includes/plugin.php on line 233”

    The code for that is:
    foreach ( (array)$all_plugins as $plugin_file => $plugin_data) {

    Although this is unedited and part of the original download.

    Please help me! I’m not sure where I’m going wrong…

Viewing 6 replies - 1 through 6 (of 6 total)
  • mrmist

    (@mrmist)

    Forum Janitor

    I think you need to empty your plugins directory (or rename it as you have done) and then add your plugin files back one by one until you find which one it is that it causing the issue.

    Unfortunately even with a fresh install this does not work with the defaults.

    The plugins.php page works if there are no plugins in the plugin folder, or if the folder does not exist. Even the having any one of the default plugins of akismet or hello.php causes it not to load.

    It’s not any specific plugin, but rather any plugin present that causes the issue, but I’m not sure why.

    I’m also a freehostia user and I’ve been having the EXACT same problem, and after seeing your post realized that it was probably a problem with them and not wordpress. Whether or not that’s true, I found a workaround and now I can see and edit plugins and do everything I could before the upgrade.

    From your freehostia account login page, go to edit myphp settings and set it to myphp 4.0 instead of 5.0. That’s it. Now, I don’t know if that will cause problems for something else, but so far so good.

    I believe this to be the case. Thanks for the help randomplaydo, you helped me out.

    I sent in a ticket to freehostia inquiring about the PHP5 version.
    PHP Version 5.0.5 apparently.

    So until then, this is probably the best way around it until they decide to upgrade. PHP4 it is for now.

    It’s an out of memory problem. PHP5 has a memory limit. Go back to PHP5 and up the memory limit by adding the below line to the very top of your site’s root .htaccess file to resolve this problem.

    php_value memory_limit 1000M

    I am having the same problem!

    I can’t downgrade to PHP4 and I have tried

    php_value memory_limit 1000M

    It is still having the same issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Admin Dashboard Plugins.php page blank in WordPress 2.7’ is closed to new replies.