Support » Plugin: Ecwid Ecommerce Shopping Cart » Admin Dashboard "My Ecwid Store" Link

  • Resolved Shawn


    We initially setup the store on a temp page (private), hidden from public view until it went live. We have since created our store page (on a different page) and made it live and it works fine. In the admin dashboard, there is a link for the Ecwid plugin at the top of the page. In that menu system is a link for “My Ecwid Store”. Currently, this link points to our temp page and not our live store. Not a biggie since only the admin will see this link, but still a bug. In our Ecwid account we initially listed the temp store page, but updated to the live store page. Seems this information is not being passed back (or retrieved) by the Ecwid WordPress plugin. I’m posting this in the Ecwid help/forum as well.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hello,

    When you install our WordPress plugin, it automatically creates a ‘Store’ page which is then used for displaying your store. We highly recommend using that page for your store, because of the following:
    1) That page is connected with the plugin settings and you can manage your store layout right from the plugin settings.
    2) That page contains the shortcodes like [ecwid_script][ecwid_search] etc, which in addition to generating of widgets, generate the necessary meta tags and the catalog structure for search engines to index your store (more details).

    If you integrate you store on another page with plain integration codes from your control panel, the functions above will not work.

    So, I’d recommend using the automatically created store page. You can rename it using the built-in WordPress page management tools so why create another page? On the other hand, if you deleted the store page or you simply want to move your store to another page, you can use this instruction for keeping the plugin work as it should:“]

    The “My Ecwid Store” link in the plugin drop-down menu always refers to the created plugin’s store page. It is actually expected behavior. As to the ‘storefront URL’ setting in your control panel, it doesn’t anyhow affect your WordPress plugin (the option is not for that). For the details on the Store URL setting, please refer to this article in our knowledge base:



    I have since restored the orginial store page, although named differently, and it works fine now. Didn’t know about the search engine indexing either. RTFM I guess. Thanks for the details and store is working great still, operator error. 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Admin Dashboard "My Ecwid Store" Link’ is closed to new replies.