Support » How-To and Troubleshooting » Admin can’t post under his own name

Admin can’t post under his own name

  • I have just built a site and am the admin. I originally made a few posts and was able to select myself as the author. Now I’ve added 2 more members as Editors, but when I write a Post or Page, it doesn’t show me as an option to choose as the author, only the two editors, so if I write something I must post as someone else. Any ideas?

Viewing 15 replies - 1 through 15 (of 15 total)
  • i have the same trouble. I hope someone post a solution soon.

    Same problem here…just started this morning.

    Not sure what the heck is up with this….

    Hi there, why don’t you take a look in your profile, you could change your nickname, and choose what you want displayed.
    hope it helps. Mike.

    It doesn’t matter, I have something in as my nickname as a user, it’s just not an option when writing a post. Only my 2 editors nicknames show up there as choices. There are 3 of us registered on the site, me as admin and 2 editors. I can do whatever I want but when I go to write a post, my only options to choose from as the post author are the other 2 which are editors. I have tried to change my nickname but it make no difference, only 2 choices appear on the post author drop down. However, before I added the other 2 logins I was there as a choice.

    Same Problem here. Don’t know if it was the upgrade to WP 2.6

    Maybe once you have “Authors”, you have to make yourself an Author, too. Means you have to add yourself as a user and set this ID as an Author. Worked for me this way.

    I don’t think it would require that, I would have thought some WP pro would have mentioned that within the last month. You shouldn’t need 2 logins and it shouldn’t take away abilities of the Admin, that doesn’t make good sense. I’ve also not gone to 2.6 yet, this was happening before it was even out.

    Something new to add to the mystery. I logged in yesterday and made a post on this blog and it had my name there to choose from. Today I logged in to make another post and it doesn’t, but if I go look at the one from yesterday I can still go to the drop down and see all 3 of us as options for me to choose. Weird.

    I am having exactly the same problem, on two different WordPress installations, and it’s happened before and after an upgrade to 2.6. See http://zahambie.com/blog/2008/06/30/ownership-issues/ for details of my first encounter; but the odd fix I discovered there is not working on the newest version of the bug.

    I just upgraded 3 of my sites to 2.7 and this one site is still having this issue, I am still the admin and still can’t write a post under my own name.

    This is one avenue that usually fixes that problem:
    1.Create new admin user (e.g. newadmin) with Administrator Role
    2.Login as ‘newadmin’
    3.Degrade the old ‘admin’ user to Role of Subscriber and Save
    4.Promote the old ‘admin’ back to Administrator Role and Save
    5.Login as the old ‘admin’

    If that doesn’t work try:
    1.Create a new admin user (e.g. newadmin) with Administrator Role
    2.Login as ‘newadmin’
    3.Delete the old ‘admin’ user and assign any posts to ‘newadmin’
    4. Create ‘admin’ user with Administrator Role
    5. Login as ‘admin’
    6. Delete ‘newadmin’ user and assign posts to ‘admin’

    The first one worked for me. Thanks!

    Is this bug added to bug tracker? 2.7.1 version have same issue

    I’m having this problem with 2.7.1 but it only manifests itself if I do a quick edit on a post, only the 2 contributor accounts are available and not my admin account.

    The first one worked for me.


    Heh, in Codex recommended remove default admin account, cause it’s a good target for hackers, so probably much useful was done it, it’s fix 1 issue and one possible issue )

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Admin can’t post under his own name’ is closed to new replies.