WordPress.org

Forums

Admin cannot see private pages (8 posts)

  1. rad_thundercat
    Member
    Posted 6 years ago #

    Like the title says, I (admin) cannot see pages that are checked 'Keep this page private'

    I can see the pages when they are not set to private.

    Everything was working fine (admin could see private pages) until I started messing around with a few role/user plugins for cms management. These included, role-scoper_.9.27, rolemanager-2.2.2, and disclose-secret.

    I deactivated all the plugins (even deleted them off the server), and copied fresh wordpress-2.6.1. files to the server to hopefully fix anything the plugins would have changed.

    The problem is still there; admin cannot see private pages.

    Clearing the cache didn't fix anything.

    Can anyone explain what might have happened and how I can fix it?

    Thank you!

  2. rad_thundercat
    Member
    Posted 6 years ago #

    Figured it out:

    I had two users setup as admin. As soon as I knocked the other one out, everything worked right.

  3. rad_thundercat
    Member
    Posted 6 years ago #

    Scratch that previous post. -I still have the problem.

    Admin can view private *posts*, however, cannot view private *pages*.

    What is the deal?

  4. jeronimo.spotorno@gmail.com
    Member
    Posted 6 years ago #

    I am using WP 2.61 and I have a similar problem, did you find a solution for your Problem?

    Thanks,
    Jeronimo

  5. funbsd
    Member
    Posted 6 years ago #

    2.6.2,the same,can anyone help?

  6. MichaelH
    Member
    Posted 6 years ago #

    I am not seeing that problem on 2.6.2. Not Role Manager, no Role Scoper, no Disclose Secret plugins installed.

    Created private page as Joe (user with Administrator role).

    Log-in as admin user and was able to see the page in Manage->Pages and was able to view and edit Joe's private page.

  7. funbsd
    Member
    Posted 6 years ago #

    I want private page showed in navimenu when I login,not only in Manage->Pages,how?

  8. whatsthatcat
    Member
    Posted 6 years ago #

    Using 2.7. Same thing is happening to me. I only have one user, and it's obviously me.

    Also, for some reason when I created the page and went to quick edit in the list view of pages, it said I had put it into a parent page that I hadn't. Also it had the box for "private" unchecked.

    Is there any way to troubleshoot this?

Topic Closed

This topic has been closed to new replies.

About this Topic