WordPress.org

Forums

Admin Cannot Edit Pages (4 posts)

  1. agMedia34
    Member
    Posted 3 years ago #

    Ive been all over the forums and google looking for a fix to this issue. Been using wordpress for 6 years now and never had anything like this happen.

    Site was working fine one day - the next I got an error that I was not authorized to view the dashboard when logging in as admin.

    I uploaded the latest version of wordpress files ... logged in again and it said database update required.

    Went through the update and was able to login - however - I have no access to the "users" section of the admin. I cannot access my "widgets" and my pages only show links to "view".

    If I "add new" ... it only allows me to "submit for review".

    Ive edited the wp_capabilities and the user meta data. Everything indicates that I "am" the admin - but the dashboard is not reflecting this properly.

    Disabled all plugins - no luck

    Added user role plugin to adjust (whatever the system thinks I am) to allow capabilities of admin - no luck

    Ive imported a backup of my database - piece by piece and narrowed the issue down to something in the wp_options table.

    Does anybody have any ideas that I havent thought of yet, or every had this issue and was able to resolve?

    Thanks in advance. This is driving me nuts.

  2. jnhghy
    Member
    Posted 3 years ago #

    Hi,
    try to disable all plugins and then reisntall wp-admin, I'm thinking a plugin is rewriting wp_options when you access the admin area ...
    Regards

  3. agMedia34
    Member
    Posted 3 years ago #

    Did that. Disabled all plugins ... ran database optimize tool, clean up tool, and orphan options removal tool. Backed up my sql file, reinstalled, started putting my sql back in and as soon as my wp_options table was populated ... No longer have admin access.

  4. creationhub
    Member
    Posted 2 years ago #

    I upgraded to wordpress 3.5. Now I cannot edit any pages or posts at all.
    Disabled all my plugins did not work at all. Somebody help me.

Topic Closed

This topic has been closed to new replies.

About this Topic