WordPress.org

Support

Support » Plugins and Hacks » WP Admin UI Customize » Admin bar save error (v1.4 wp3.7)

Admin bar save error (v1.4 wp3.7)

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Author gqevu6bsiz

    @gqevu6bsiz

    In my case, I tried in the WordPress3.7 and this plugin 1.4, I was saved.
    There is no error.
    Admin Bar Menu setting screen

    Could you tell me your ScreenShot on Admin Bar Menu setting, please?
    This is the Javascript Console in particular.

    Thanks,
    gqevu6bsiz

    Plugin Author gqevu6bsiz

    @gqevu6bsiz

    Thank you for your screenshot and I appreciate your help!
    But, I’m sorry, Javascript errors does not include probably in the it screenshot.

    Is this what you mean?

    I think maybe to Javascript error cause for save error.

    Could you tell me your screenshot to include Javascript error?

    Thanks,
    gqevu6bsiz

    I’m not sure there were any javascript errors. Here are two screenshots

    Before click save

    After click save

    If I click persist and try again just the warning from “before click” persists and no other errors.

    Have I done this right?

    By the way, the warning is not the problem because it is there on all pages of the plugin.

    Plugin Author gqevu6bsiz

    @gqevu6bsiz

    Thank you for your screenshot!

    “You don’t have permission to access /wp-admin/admin.php on this server”

    I’m sorry for the convenience.
    I was mistaken understand to your problem. It is maybe server error.

    Let me think about your server error to my plugin.

    Could you send me to possible your server error LOG?
    Or, Could you tell me do you have error to if use other plugins(plugin to use admin.php)?

    Could you also refer to here?
    http://wordpress.org/tags/500-internal-server-error

    Thanks,
    gqevu6bsiz

    server error log didn’t show any errors.

    raw server access log shows this:

    "POST /tour/wp-admin/admin.php?page=wp_admin_ui_customize HTTP/1.1" 500 - "http://*******.com/tour/wp-admin/admin.php?page=wp_admin_ui_customize_admin_bar" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:24.0) Gecko/20100101 Firefox/24.0"

    i don’t have any other plugins that use admin.php

    admin.php has permissions 644

    except this admin bar error, the plugin is great – i hope you can help …

    Plugin Author gqevu6bsiz

    @gqevu6bsiz

    Thank you for your information.

    Please let me confirm.

    except this admin bar error

    Could you tell me error on other settings of WP Admin UI Customize (side menu, general, dashboard, etc..)?
    Is it error to only Admin Bar Menu settings?

    Thanks,
    gqevu6bsiz

    Yes, only Admin Bar Menu settings.

    Plugin Author gqevu6bsiz

    @gqevu6bsiz

    Yes, only Admin Bar Menu settings.

    Thank you for your reply.

    If you don’t mind, Please use this developer version.
    Developer Version of WP Admin UI Customize

    Could you tell me your problem is solved?

    Thanks,
    gqevu6bsiz

    Thanks.

    The problem is not solved.

    Plugin Author gqevu6bsiz

    @gqevu6bsiz

    Thank you for your kindness feedback!

    You are welcome, but I think you misunderstand:

    The problem is NOT solved

    Admin bar bar settings still throw up server error when trying to save …

    Any more ideas?

    Plugin Author gqevu6bsiz

    @gqevu6bsiz

    The problem is NOT solved

    I’m sorry I misunderstand and for the convenience.

    Could you tell me error on when try to debug?

    • define(‘WP_DEBUG’, true);
    • define(‘WP_DEBUG_LOG’, true);
    • define(‘WP_DEBUG_DISPLAY’, true);

    Debugging_in_WordPress

    Thanks,
    gqevu6bsiz

    Notice: wp_enqueue_script was called incorrectly. Scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, or login_enqueue_scripts hooks. Please see Debugging in WordPress for more information. (This message was added in version 3.3.) in /home/*****/public_html/*****.com/tour/wp-includes/functions.php on line 3060
    
    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/*****/public_html/*****.com/tour/wp-includes/functions.php on line 3017
    
    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/*****/public_html/*****.com/tour/wp-includes/functions.php on line 3017
Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Admin bar save error (v1.4 wp3.7)’ is closed to new replies.
Skip to toolbar