WordPress.org

Forums

[resolved] Admin Bar not showing AT ALL anywhere (11 posts)

  1. Fighter02
    Member
    Posted 3 years ago #

    I've recently installed the latest wordpress from scratch and noticed the great admin bar on the default Twenty Eleven theme. I purchased a theme and there's NO admin bar in it at all, no blank space even.

    This happens on both the frontend pages and the backend pages, meaning there's no admin bar on the dashboard either.

    When I switch back to Twenty Eleven, the admin bar is there on the site and dashboard again.

    The theme I'm using is EugeneO Sideways, and it calls wp_head() and wp_footer() on header.php and footer.php, though there's some code after both calls, I've tried moving the wp_head and wp_footer calls to before </head> and before </body> but that does nothing... and I think it even breaks some functionalities.

    Well Thank you for any tips! I'm just lost with this!

  2. Nikki Blight
    Member
    Posted 3 years ago #

    Try adding:
    add_theme_support( 'admin-bar' );
    to your functions.php file.

  3. Fighter02
    Member
    Posted 3 years ago #

    Thanks for the suggestion but I'm afraid that did nothing at all! :(

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

  5. Fighter02
    Member
    Posted 3 years ago #

    I only have 2 plug-ins installed (nextgen gallery and akismet), and the admin bar was not showing before I installed any plug-ins, but I'll try it anyway...

    Switching to Twenty Eleven shows the admin bar as I said on my original post, so its a problem of the theme I'm using that's not showing the admin bar at all.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Edit your theme's footer.php file and ensure that it includes <?php wp_footer(); ?> immediately before </body>.

  7. Fighter02
    Member
    Posted 3 years ago #

    Already tried that but it doesn't work, I found that suggestion on many google results... but nothing.

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    And have you checked for wp_head() in header.php?

  9. Fighter02
    Member
    Posted 3 years ago #

    yup I've done that as well... thanks for the suggestions but sadly it's none of the common problems. :(

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    But it's definitely theme specific, so I'm afraid you're now going to have to try eliminating bits of your theme until you find the culprit. If it was me, I'd start with functions.php and disable as many custom functions as I could.

  11. Fighter02
    Member
    Posted 3 years ago #

    well! it's solved! my theme has a lot of files with functions linked on functions.php so I opened the main one and found that the admin bar was disabled by the theme! So I removed that and it works! :D

    Now I have to adjust the scroll bar problem and all done.

    Thank you very much guys! :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags