WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Admin Bar Not Appearing on Front Page in Safari (4 posts)

  1. Nadreck
    Member
    Posted 3 years ago #

    I've been running the 3.3 "Aortic Dissection" nightly builds, and recently I've noticed the admin bar not appearing on the front page when running in Safari. It still appears in Firefox, Camino, and Chrome, but I can't for the life of me figure out why it isn't showing up in Safari anymore.

    I've tried turning off extensions in Safari, and plugins in wordpress, getting back to bog standard -- still no go. I'm at a loss on what to try next. Since this behavior only started appearing in a recent nightly build, I opted to post this in the alpha/beta forums, rather than the troubleshooting forums. Thoughts?

  2. Randy Sandberg
    Member
    Posted 3 years ago #

    Hi Nadreck,

    I just tried to reproduce your observation but could not. I'm running Mac OS 10.7.1 and Safari 5.1 on my client and XAMPP 1.7.3, WordPress 3.3-aortic-dissection, Twenty Eleven 1.2, (also tried the Twenty Ten 1.2 theme), and WordPress Beta Tester 0.95 (to acquire the latest WP "Bleeding edge nightlies") on the server.

    Note 1: "Show Admin Bar when viewing site" is checked in my user profile.

    Note 2: I just re-updated to be sure I have the latest WordPress. Moreover, I did a CMD+R (Command Refresh) just to be sure no old stuff was lingering on my homepage.

    Are you on a Mac or Windows? If you're on a Mac, might I suggest creating a new user and trying your test there. This way you'll quickly know whether it's a user or globally related issue.

    Hope this helps! :-)

  3. Nadreck
    Member
    Posted 3 years ago #

    I'm running Safari 5.1 on Mac OS X 10.6.8, running the latest nightly (updated it again tonight, same deal), gathered originally via svn and now through the built-in updater, running a child theme of Twenty Eleven (a few minor tweaks to css, nothing that even touches the header).

    I've verified the "Show Admin Bar when viewing site" option is checked, and moreover, the same account has the admin bar displayed when viewed in Chrome and Firefox.

    I've had a small handful of plugins running the past (Akismet, Jetpack, Twitter Tools, WPTouch, Wordbooker), but have turned them all off in the process of trying to debug this issue. I also had a few extensions running in Safari (AdBlock, LittleSnapper, 1Password, Coda Notes), but those are all turned off now as well. I refreshed, then cleared, then refreshed again, still no luck. Went into the Develop menu and turned off caching entirely -- still no admin bar.

    Not really sure what else to try at this point -- on the same user account, at the same time, the admin bar is present on all other browsers, except Safari.

  4. Nadreck
    Member
    Posted 3 years ago #

    Update (Resolved):

    I finally have the admin bar back. What it took was manually logging out and the back in again. I don't know why it happened in the first place, and I don't know why it didn't go away when I cleared my cache and my cookies, but: logged in, logged out, logged back in -> admin bar.

Topic Closed

This topic has been closed to new replies.

About this Topic