Support » Fixing WordPress » Admin bar missing for Editor

  • Hello good people 🙂

    I have a small problem. I’ve added an editor and he doesn’t see the admin bar. It was there before?

    I need it to edit post, create new ones and so on.

    Is it a bug or do they normally not see it? Can I add some settings to change it?

    In the user menu, it is checked to show the tools menu, but there is nothing. When I change the role to admin, admin bar on the website is there.

    User can see the admin menu when in admin panel, but when browsing the website, nothing.

    Thank you

Viewing 10 replies - 1 through 10 (of 10 total)
  • Go to all users. Click edit under your editor and make sure “Show Toolbar when viewing site” is checked.

    Hi. It is already. Tries turning off and on, but no change.

    Sorry, have to ask. You did hit apply?

    On that same page (using Chrome) hit F12. Then try it and any javascript errors will show up.

    I did 🙂

    Here is the log:

    user-edit.php?user_id=390&updated=1&wp_http_referer=%2Fwp-admin%2Fusers.php:77 GET https://www.ossaw.atfl_url_js/seo-firelinks_back.js?ver=4.6 net::ERR_NAME_NOT_RESOLVED
    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,zxcvbn-async&ver=4.6:9 JQMIGRATE: Migrate is installed, version 1.4.1

    Any chance what is this?

    Back to basics.

    Have you tried:
    -deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    -switching to the default theme to rule out any theme-specific problems.

    When I disable:

    Simple WordPress Membership

    Editor can see the toolbar.

    I should write to them?

    Go to the plugins support forum for each. Both have to be disabled?

    This has been mentioned in other forums for Chrome:

    Go to chrome://flags/#disable-slimming-paint
    Enable the “Disable slimming paint” option.
    Ensure that the “Enable slimming paint” option below it is not turned on.
    Relaunch Chrome.

    If nothing mentioned in the post works, try changing the WordPress Address (URL) and the Site Address (URL) at Settings > General by adding or removing www to them.

    If it works, you can switch it back then.

    Worked for me!

    For me, this was caused by my Cache Plugin (WP fastest Cache). There is a setting button in that plugin to show (or not show) the cached pages/posts to logged in users. As a logged in admin I was seeing the cached pages (no admin toolbar). I unchecked that box, hit refresh and then the toolbar is back as i was no longer seeing the cached version.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Admin bar missing for Editor’ is closed to new replies.