WordPress.org

Support

Support » How-To and Troubleshooting » Admin bar disappears when I "View my site"

Admin bar disappears when I "View my site"

  • I have been using wp.org for quite a while now, but today I’ve encountered a big problem.

    The dashboard looks OK, as it always does, but when I click “view my site”, I am redirected to the site as usually, but the gray admin bar on top disappears. I don’t know whether I am getting signed out or not, when I return to the dashboard it all seems fine!

    Therefore, I can’t access my dashboard while viewing my website. It’s really annoying!

    Could you help me please?

    Thank you very much!

Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the default theme by renaming your current theme’s folder inside wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder and the wp-config.php & root .htaccess files – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    – running the upgrade manually via wp-admin/upgrade.php

    I’m not sure it’s that complicated, this issue just seems to have appeared out of the blue, I didn’t do anything to cause (or maybe I did something accidentally)…

    esmi

    @esmi

    Forum Moderator

    There is no magic bullet in these situations. This is just the start of basic troubleshooting – a process of elimination deliberately designed to locate the root cause as quickly as possible by first removing the most obvious and common culprits via a series of (often) temporary steps.

    Your theme & plugin settings are saved in your database and should be retained for future use.

    Actually, it seems the posts have the admin bar, it’s just the home page that lacks it…?

    Now, sometimes the admin bar appears, sometimes it doesn’t.

    Does anyone know what to do?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Admin bar disappears when I "View my site"’ is closed to new replies.
Skip to toolbar