Support » Plugin: Asset CleanUp: Page Speed Booster » Admin area -> plugins -> loading super slow

  • Resolved Andre

    (@picturebreeze)


    I’m not sure what exactly is causing the issue.
    I’ve noticed my WP admin area becoming very slow, especially the plugins section. It took longer than 30s to load, and whenever I’ve activated a new plugin it took literally several minutes until WP admin became responsive again.

    I’ve spent hours with checking plugins, used a Gravity Forms debug tool to disable all plugins and custom themes, and then enable one by one again.

    The conclusion is that as soon as I enable Asset Cleanup the plugins section becomes super slow. Once I disable Asset Cleanup everything goes back to speed.

    I really like the frontend benefits of the plugin but it makes it almost impossible to work on the backend.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @picturebreeze thank you for reporting this and I’d definitely look into it as it’s enough one setting or an incompatibility issue between plugins to cause this which is surprising me, to be honest as from what you’re saying it takes an awful lot of seconds to go through the Dashboard’s pages when the plugin is active. I’ve never experienced it in any environment and I’m positive these kind of cases are fairly isolated.

    I’d like to know whether you’re on dedicated or shared hosting, your hosting company, PHP version and a list of plugins that you use. Ideally, I’d like your “System Info” from “Tools” (Asset CleanUp). If you can hide the website URL and other sensitive data and provide me the rest of the contents that would be great. The more information you could provide to me, the better! Also, have you noticed this in previous versions of the plugin? Or is it something specific to 1.3.3.8?

    Andre

    (@picturebreeze)

    I’m on shared hosting.
    I can’t say anything about previous versions of the plugin. I just installed it maybe 2 weeks ago.

    ### Begin System Info ###

    # Site Info
    Site URL: https://mywebsitedomain.com
    Home URL: https://mywebsitedomain.com
    Multisite: No

    # Hosting Provider
    Host: DBH: localhost, SRV: mywebsitedomain.com

    # User Browser
    Browser Name: Chrome
    Browser Version: 76.0.3809.100
    Browser User Agent String: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36
    Platform: Apple

    # WordPress Configuration
    Version: 5.2.2
    Language: en_US
    Permalink Structure: /%postname%/
    Active Theme: Hello Elementor Child 1.0.0
    Show On Front: page
    Page On Front: …
    Page For Posts: Unset
    ABSPATH: /www/htdocs/…
    WP_DEBUG: Disabled
    Memory Limit: 40M

    # WordPress Uploads/Constants
    WP_CONTENT_DIR: /www/htdocs/…/wp-content
    WP_CONTENT_URL: https://mywebsitedomain.com/wp-content
    UPLOADS: Not set
    wp_uploads_dir() path: /www/htdocs/…/wp-content/uploads/2019/08
    wp_uploads_dir() url: https://mywebsitedomain.com/wp-content/uploads/2019/08
    wp_uploads_dir() basedir: /www/htdocs/…/wp-content/uploads
    wp_uploads_dir() baseurl: https://mywebsitedomain.com/wp-content/uploads

    # Active Plugins (“plugins” directory)
    AffiliateWP: 2.3
    AffiliateWP – Allow Own Referrals: 1.0.2
    Asset CleanUp: Page Speed Booster: 1.3.3.8
    Autoptimize: 2.5.1
    Autoptimize CriticalCSS.com Power-Up: 1.16.0
    Better Search Replace: 1.3.3
    Bulk Actions Pro for Gravity Forms: 1.2.22
    Comments Ratings: 1.1.6
    Elementor: 2.6.8
    Elementor Pro: 2.6.2 (new version available – 2.6.3)
    Google Analytics Dashboard for WP (GADWP): 5.3.8
    Gravity Forms: 2.4.11
    Gravity Forms Collapsible Sections: 1.0.13
    Gravity Forms Coupons Add-On: 2.9
    Gravity Forms Debug Add-On: 1.0.beta11
    Gravity Forms Event Tracking: 2.3.10
    Gravity Forms Limit Date Range: 2.1.1
    Gravity Forms Partial Entries Add-On: 1.4
    Gravity Forms PayPal Standard Add-On: 3.2
    Gravity Forms Polls Add-On: 3.4
    Gravity Forms Stripe Add-On: 2.7 (new version available – 2.9)
    GravityWP – CSS Selector: 1.0.1
    Newsletter: 6.1.6
    Popup Trigger URL for Elementor Pro: 1.0.1
    Remove Dashboard Access: 1.1.3
    Styles & Layouts Gravity Forms: 4.2.3
    The SEO Framework: 3.2.4
    UpdraftPlus – Backup/Restore: 1.16.16
    WP Fastest Cache: 0.8.9.6

    # Inactive Plugins (“plugins” directory)
    Affiliates GravityForms: 3.0.0
    Affiliates Pro: 4.2.0
    Gravity Forms Bulk Add Fields: 1.0.2
    Gravity Forms Color Picker: 1.0.3
    Itthinx Updates: 1.2.0
    Really Simple Affiliate Program: 2.1

    # Webserver Configuration
    PHP Version: 7.1.30-nmm1
    MySQL Version: 5.6.44
    Webserver Info: Apache

    # PHP Configuration
    Memory Limit: 256M
    Upload Max Size: 200M
    Post Max Size: 200M
    Upload Max Filesize: 200M
    Time Limit: 30
    Max Input Vars: 10000
    Display Errors: On (php.ini value: 1)

    # PHP Extensions
    cURL: Supported
    fsockopen: Supported
    SOAP Client: Installed
    Suhosin: Not Installed

    # Session Configuration
    Session: Disabled

    # Asset CleanUp Configuration
    Has read “Stripping the fat” text: Yes

    Manage in the Dashboard: Yes (direct)
    Manage in the Front-end: No
    Input Fields Style: Enhanced
    Hide WP Files (from managing): Yes
    Enable “Test Mode”? No

    Minify loaded CSS? No
    Minify loaded JS? No
    Combine loaded CSS? No
    Combine loaded JS? No
    CSS/JS Storage Directory: /www/htdocs/…/wp-content/cache/asset-cleanup/ (writable)

    Disable Emojis? Yes
    Disable Dashicons Site-Wide For Guests? Yes
    Disable Gutenberg CSS Block Editor (site-wide)? No
    Disable jQuery Migrate (site-wide)? No
    Disable Comment Reply (site-wide)? No

    Remove “Really Simple Discovery (RSD)” link tag? Yes
    Remove “Windows Live Writer” link tag? Yes
    Remove “REST API” link tag? Yes
    Remove Pages/Posts “Shortlink” tag? Yes
    Remove “Post’s Relational Links” tag? Yes
    Remove “WordPress version” meta tag? Yes
    Remove All “generator” meta tags? Yes
    Remove Main RSS Feed Link? Yes
    Remove Comment RSS Feed Link? Yes

    XML-RPC protocol: Disable XML-RPC Completely

    # Asset CleanUp: CSS/JS Caching Storage
    Total cached assets: 0 (N/A)

    # Asset CleanUp: Database Storage
    Table: options
    — Option Name: wpassetcleanup_bulk_unload / Option Value: {“styles”:{“post_type”:{“page”:[]}},”scripts”:{“post_type”:{“page”:[]}}}
    — Option Name: wpassetcleanup_first_usage / Option Value: 1565556518
    — Option Name: wpassetcleanup_global_data / Option Value: {“styles”:{“preloads”:[]},”scripts”:{“preloads”:[]}}
    — Option Name: wpassetcleanup_global_unload / Option Value: {“styles”:[“wp-block-library”,”google-fonts-1″],”scripts”:[“jquery-migrate”]}
    — Option Name: wpassetcleanup_hide_tracking_notice / Option Value: 1
    — Option Name: wpassetcleanup_settings / Option Value: {“wiki_read”:”1″,”dashboard_show”:”1″,”dom_get_type”:”direct”,”frontend_show_exceptions”:”et_fb=1\r\nct_builder=true\r\nvc_editable=true\r\npreview_nonce=\r\n”,”assets_list_layout”:”by-location”,”assets_list_layout_plugin_area_status”:”expanded”,”assets_list_layout_areas_status”:”contracted”,”assets_list_inline_code_status”:”expanded”,”input_style”:”enhanced”,”hide_core_files”:”1″,”clear_cached_files_after”:”10″,”minify_loaded_css_exceptions”:”(.*?)\\.min.css\r\n\/plugins\/wd-instagram-feed\/(.*?).css”,”minify_loaded_js_exceptions”:”(.*?)\\.min.js\r\n\/plugins\/wd-instagram-feed\/(.*?).js”,”combine_loaded_css_exceptions”:”\/plugins\/wd-instagram-feed\/(.*?).css”,”combine_loaded_js_exceptions”:”\/plugins\/wd-instagram-feed\/(.*?).js”,”disable_emojis”:”1″,”disable_oembed”:”1″,”disable_dashicons_for_guests”:”1″,”remove_rsd_link”:”1″,”remove_wlw_link”:”1″,”remove_rest_api_link”:”1″,”remove_shortlink”:”1″,”remove_posts_rel_links”:”1″,”remove_wp_version”:”1″,”remove_generator_tag”:”1″,”remove_main_feed_link”:”1″,”remove_comment_feed_link”:”1″,”remove_html_comments”:”1″,”remove_html_comments_exceptions”:””,”local_fonts_display”:””,”local_fonts_preload_files”:””,”google_fonts_combine”:”1″,”google_fonts_display”:”fallback”,”google_fonts_preload_files”:””,”disable_xmlrpc”:”disable_all”,”hide_assets_meta_box”:””,”hide_options_meta_box”:””,”frontend_show”:””,”hide_from_admin_bar”:””,”test_mode”:””,”combine_loaded_css”:””,”combine_loaded_css_for_admin_only”:””,”combine_loaded_js”:””,”combine_loaded_js_for_admin_only”:””,”combine_loaded_js_defer_body”:””,”minify_loaded_css”:””,”minify_loaded_js”:””,”disable_wp_block_library”:””,”disable_jquery_migrate”:””,”disable_comment_reply”:””,”allow_usage_tracking”:””,”google_fonts_preconnect”:””,”hide_meta_boxes_for_post_types”:[]}

    Table: postmeta
    — Post ID: 73 / Meta Key: _wpassetcleanup_no_load / Meta Value: {“scripts”:[“jquery-raty”,”reviews-scripts”],”styles”:[“jquery-raty-style”]}

    Table: usermeta
    No records

    Table: termmeta
    No records

    ### End System Info ###

    Plugin Author Gabe Livan

    (@gabelivan)

    @picturebreeze thank you for the details. Everything looks good. I haven’t had a chance to test all the plugins.

    Are you comfortable removing a line of code? If yes, you can edit the following file /wp-content/plugins/wp-asset-clean-up/wpacu.php and remove the line require_once WPACU_PLUGIN_DIR.'/freemius-load.php';
    Or comment it like this: //require_once WPACU_PLUGIN_DIR.'/freemius-load.php';

    This will deactivate the Freemius SDK. I have a suspicion that it adds up to that load time in your WordPress environment, for some reason.

    • This reply was modified 5 months, 1 week ago by Gabe Livan.
    • This reply was modified 5 months, 1 week ago by Gabe Livan.
    Andre

    (@picturebreeze)

    Thanks. I took that line out and it seems like it solved the problem. Going to watch it closely for a few days.
    Thanks for the help.

    Plugin Author Gabe Livan

    (@gabelivan)

    @picturebreeze note that I’ve implemented a way to disable “Freemius Insights & Analytics” which will be pushed in the next update (which will be 1.3.3.9). Once you perform the Asset CleanUp plugin update, just go to “Settings” -> “Plugin Usage Preferences” and mark “Disable Freemius Insights & Analytics” (see the reference below)

    wpacu-deactivate-modal-option

    • This reply was modified 5 months, 1 week ago by Gabe Livan.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.