Support » Plugin: Asgaros Forum » Admin and User are using different languages

  • Resolved Jonas930

    (@jonas930)


    Hi @asgaros !
    Thanks for creating this cool forum plugin!

    I am a small game creator as habit. I always need some forum like community webpage for my fans to repost bugs or me to posting a update imformation (just like what this forum doing here).

    Aside those much thanks for you. I have a problem on language displaying. So on my dashborad, I have chinese as my main language, and also have “asgaros-forum-zh_TW.po” and “asgaros-forum-en_US.po” both under “wp-content/languages/plugins”. Then, the forum now is in Chinese becuase I have Chinese dashboard as well.

    After one day, one of fans who only understand English told me that the forum is in Chinese not English. Then, I did some check about language setting stuff. I found out the plugin’s languages are only go with the admin’s languages, not the languages user set in their profiles.

    So, is this a bug of plugin or there are some setting I did wrong?

Viewing 3 replies - 1 through 3 (of 3 total)
  • BTW, I did upload my translation file on “https://translate.wordpress.org/projects/wp-plugins/asgaros-forum”
    So if there are some Chinese speaker or native Chinese can check if translation is fit or not.

    Plugin Author Asgaros

    (@asgaros)

    Hello @jonas930

    Asgaros Forum should use the language which WordPress sets for the current environment. This is either based on the general settings or the users language. However, if could be possible that another language- or caching-extensions loads wrong files because of some misconfiguration. Can you check this?

    It also seems, that WordPress always uses the default-language for the frontend also in other areas (like the top admin bar) even when the user set another language in his profile? It could be possible that this setting is only used in the admin area.

    • This reply was modified 1 month, 2 weeks ago by  Asgaros.

    Didnt really know where I did wrong. But, I did put both language po mo files on both folders. It still show the same language as what admin set in the dashboard. Also, I check some other plugins to test, most of them do have same problem. I think that may be the wordpress itself peoblem.

    Anyways, thanks for this awesome plugin. I will keeping eyes in it!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.