Support » Plugin: Jetpack by WordPress.com » Admin and Non-Admin Accounts

  • Hi,

    I have a site powered by wordpress. I have an admin account for the admin stuff, which I rarely log in to.

    I have a separate account that can only created posts etc, which I use as the primary account for adding content, for security reasons.

    I’ve enabled JetPack and linked the AdminAccount to my wordpress account, which means I can’t use it for my author account.

    Is there a good best-practice for this? Do I need to have a second wordpress.com account to manage it?

    Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support lizkarkoski

    (@lizkarkoski)

    Hi @themikefb

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    Contact Support

    Plugin Support lizkarkoski

    (@lizkarkoski)

    You could also connect JP with the other account, and then login/logout to the other admin user when you need access to more admin-related stuff.

    This page explains the different roles/status in users:
    https://en.support.wordpress.com/user-roles/

    I’d personally say that the best practice is to use the Admin role for everything admin related. We understand that some people might need different roles/account for different things.

    Keep at it and I’m sure you’ll be able to figure out what works best for you.

    Sorry for the delay replying, it’s been a busy week!

    Site is https://hillsangels.cc

    It seems that I have to enable jetpack with an admin account, which means linking the admin account to my wordpress account. Then if I want to use a feature like share to social media, I have to have the author account linked to a wordpress account and it can’t be the same wordpress account. So I’ve had to set up a second wordpress account for the author account.

    I was hoping there would be a slicker way of managing that.

    Cheers,

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.