WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] admin-ajax.php imgedit-preview header problem ( v2 / WP3.7 )

[Resolved] admin-ajax.php imgedit-preview header problem ( v2 / WP3.7 )

  • I use the “Post thumbnail Editor” , but the page for select area for the thumbnail did not show the main image.

    There is one year @hugofcampos had found a solution , but the post is closed to replies.

    Well, with WP 3.7, I had the same problem, so I found a similar solution ( not the same file, nor function )

    Hope that help :

    class-wp-image-editor-gd.php line 396

    I added while (@ob_end_clean()); in the stream function.

    public function stream( $mime_type = null ) {
    		list( $filename, $extension, $mime_type ) = $this->get_output_format( null, $mime_type );
    
    		while (@ob_end_clean());
    
    		switch ( $mime_type ) {
    			case 'image/png':
    				header( 'Content-Type: image/png' );
    				return imagepng( $this->image );
    			case 'image/gif':
    				header( 'Content-Type: image/gif' );
    				return imagegif( $this->image );
    			default:
    				header( 'Content-Type: image/jpeg' );
    				return imagejpeg( $this->image, null, $this->quality );
    		}
    	}
Viewing 5 replies - 1 through 5 (of 5 total)
  • #sorry, I messed up the bbcode

    Hi,

    I’m still having this bloody error since at least 2 months and searched all the web to solve it (permissions, plugins, themes…)!

    I tried the previous but still have the admin-ajax.php related issue :

    Warning: Cannot modify header information – headers already sent by (output started at /homez.541/sebroux/www/sjsl/wp-config.php:1) in /homez.541/sebroux/www/sjsl/wp-includes/class-wp-image-editor-gd.php on line 406

    Any help appreciated. thx

    Bonjour sebroux,

    I think it is not the same problem.

    It seems that there is an output started in your config.php.
    Check if you have some space before php tag on config.php.

    Hi thanks for your feedback. I checked config.php which has no space before php tag.

    I’m going crazy about this issue that everyone seems to experience!

    Have you tried with a fresh new install of WP ? Or with a default theme ? Deactivated some extension ?

    Perhaps it’s a theme/extension related issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] admin-ajax.php imgedit-preview header problem ( v2 / WP3.7 )’ is closed to new replies.