WordPress.org

Forums

iThemes Security (formerly Better WP Security)
admin-ajax.php 404 error after update to 4.02 (18 posts)

  1. Adam Ramshaw
    Member
    Posted 1 year ago #

    Hi,

    I updated to the latest version (4.02) and it caused a problem with the admin-ajax.php file.

    This was being called (I think) by javascript on a page that checks form details. Before the upgrade it was fine now the JS console reports that wp-admin/admin-ajax.php is giving a 404 error and the submit button will not fire.

    Deactivated the plugin and everything works again so it looks like this plug-in is responsible.

    https://wordpress.org/plugins/better-wp-security/

  2. Sir Dance A Lot
    Member
    Posted 1 year ago #

    Same thing here.
    It took me 4 hours to narrow it down to iThemes security, but exactly like you, has soon as I deactivated iThemes security, woocommerce worked again.
    And it was only the ajax that had a problem, add to cart button and checkout Place Order button.

  3. Edwin
    Member
    Posted 1 year ago #

    I have same problem. hope it'll get fix soon.

  4. Marcelo Pedra
    Member
    Posted 1 year ago #

    Same here. I had to downgrade to the previous version (non-iThemes one) to allow WooCommerce to work again.
    The other way to solve it is to disable AJAX buttons from within WooCommerce settings, but it break my site functionality...
    So, fix please!
    :)

  5. Marcelo Pedra
    Member
    Posted 1 year ago #

    oh and By the Way, the new version of this plugin also breaks the WooCommerce Shipping calculator... Sad times...

  6. siprof
    Member
    Posted 1 year ago #

    same here, shipping calculator now broken

  7. greeso
    Member
    Posted 1 year ago #

    I have the same exact problem. This is a serious issue. Ajax will only work if you are logged in to the backend. Once you log off, Ajax will stop working.

  8. igov
    Member
    Posted 12 months ago #

    Too bad that ajax stopped working after migration to iThemes security. Better WP Security was much better plugin.

    Fortunately i fixed it on my site and now ajax works together with hidden backend.

  9. Marcelo Pedra
    Member
    Posted 12 months ago #

    @igov: how did you fix it?

  10. Mik
    Member
    Posted 12 months ago #

    @igov HOW DID YOU FIX IT? I lost 2 days worth of sales thanks to this "upgrade".. Is there any way to downgrade back to wp security?

  11. Marcelo Pedra
    Member
    Posted 12 months ago #

    MikS Music: yes, you should be able to completely uninstall the plugin. Then go here and grab your desired version:
    https://wordpress.org/plugins/better-wp-security/developers/

    It should help.

  12. igov
    Member
    Posted 12 months ago #

    No need for downgrade, it is fixable. Could you please write your email address here and i will send you patched files?

  13. Marcelo Pedra
    Member
    Posted 12 months ago #

    "patched files" is a lot of fixes which you cannot share here with instructions? :(
    Can you upload it to Dropbox or the like to help others?

  14. Mik
    Member
    Posted 12 months ago #

    igov, Marcelo thanks for the reply!

    Tnx

  15. Vincent Wasteels
    Member
    Posted 12 months ago #

    Same here, waiting for official solution from plugin creators :)

  16. jazzy013
    Member
    Posted 12 months ago #

    Same here.. very bad :( please fix it soon. I had to dissable the security for the time being. So please hurry.

  17. Marcelo Pedra
    Member
    Posted 12 months ago #

    Guys, don't be crazy, don't deactivate the security of your websites!!!!!

    While the developers fix this issue, you can uninstall the failing iThemes plugin, uninstall it, and upload the last good version to your plugins folder and install it again:
    http://downloads.wordpress.org/plugin/better-wp-security.3.6.6.zip

    At least, by doing so, you will keep up your security.

  18. Webartisan
    Member
    Posted 11 months ago #

    Have the same problem here.

    As far as I can figure out it must be something related to the "Hide login area" section of BWP Security (or iThemes security, how it's called now).
    I've always used that option to change the /wp-login and /wp-admin and make a little harder to find the access to backoffice.

    If I temporarily disable the "Hide backend feature" the calls to admin-ajax.php work again.
    I suppose that is because when you don't have hide-backend enabled the ajax url is typically http://www.yoursitename.com/wp-admin/admin-ajax.php, but when you enabled it (and you're not already logged in) every calls to a page containing /wp-admin/ will generate an error.

    Personnally I'm going to downgrade to the last working version and check the progress of the fixing progresss before upgrading to a new version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic