Support » Fixing WordPress » admin-ajax.php loading error, 500 internal server error

  • akshaysihag

    (@akshaysihag)


    Hii, my map is now showing in this page and is giving me an ajax error, can anyone please help ? Already tried deactivating all plugins, no luck

    also tried renaming .htaccess file, no luck

    can please someone help me ?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator t-p

    (@t-p)

    Internal server errors (error 500) are often caused by plugin or theme function conflicts, so if you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the default theme for your version of WordPress to rule-out a theme-specific issue. If you don’t have access to your admin panel, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue.

    If that does not resolve the issue, it’s possible that a .htaccess rule could be the source of the problem. To check for this, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your SFTP or FTP client to view invisible files.

    If you weren’t able to resolve the issue by either resetting your plugins and theme or renaming your .htaccess file, we may be able to help, but we’ll need a more detailed error message. Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error again, note the date and time, then immediately check your server error log for any errors that occurred during that time period. If you don’t have access to your server error log, ask your hosting provider to look for you.

    akshaysihag

    (@akshaysihag)

    I said above i tried all this, none of this resolved it sir, I’m asking for your help….can you help please

    Moderator t-p

    (@t-p)

    Akshay, have you checked your server error logs?

    Can you quote the error shown in the error logs?

    akshaysihag

    (@akshaysihag)

    yes i have checked the server logs and there is no log for this error !! Can you help me somehow in any other way please ?

    Moderator t-p

    (@t-p)

    my map is now showing in this page and is giving me an ajax error

    Please quote the error 🙂

    akshaysihag

    (@akshaysihag)

    this is the chrome console error :

    Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    houzez_ajax_calls.js:2585 500
    houzez_ajax_calls.js:2586
    houzez_ajax_calls.js:2587 Internal Server Error

    akshaysihag

    (@akshaysihag)

    my server log is empty since 16th septemberc, its has no error of ajax whatsoever, but just to show you here it is :

    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘color’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1313
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘font-family’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1314
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘font-size’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1315
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘font-weight’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1316
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘line-height’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1317
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘text-transform’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1318
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘font-size’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1325
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘font-family’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1351
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘font-weight’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1352
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘text-transform’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1353
    [14-Sep-2017 11:20:01 UTC] PHP Warning: Illegal string offset ‘text-align’ in /home1/texassu3/public_html/wp-content/themes/houzez/inc/styling-options.php on line 1354
    [16-Sep-2017 22:56:56 UTC] PHP Warning: Illegal string offset ‘header_image’ in /home1/texassu3/public_html/wp-content/themes/houzez/template-parts/page-headers/static-image.php on line 77

    • This reply was modified 2 months ago by  akshaysihag.
    akshaysihag

    (@akshaysihag)

    Console error again :

    /~texassu3/wp-admin/admin-ajax.php Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    houzez_ajax_calls.js:2585 500
    houzez_ajax_calls.js:2586
    houzez_ajax_calls.js:2587 Internal Server Error

    Moderator t-p

    (@t-p)

    Your “houzez” theme seems to be the error.

    As I suggested in my very first reply, try switching to the unedited default Theme (Twenty Seventeen.) for a moment using FTP/ SFTP , or your web-host’s cPanel or whatever file management application your host provides (no Dashboard access required). Navigate to /wp-content/themes/ and switch to the default theme by renaming your current theme’s folder by adding “-old” to the end of the folder name. Alternately, you can remove other themes except the default theme (Twenty Sixteen.). That will force your site to use it.

    If the problem goes away, then re-upload the theme or contact the theme author.

    – Your currently used theme is not in the wordpress.org/themes/ directory.
    – If that is a commercial theme, we ask that you please go to their official support channel, so you can get support from the people who know it best.
    – Commercial products are not supported in these forums. As you are their customer; they should not have problem supporting you there.
    – Forum volunteers are also not given access to commercial products, so they would not know why your commercial theme or plugin is not working properly. This is one other reason why volunteers forward you to the commercial product’s vendors. The vendors are responsible for supporting their commercial product.

    akshaysihag

    (@akshaysihag)

    Sir i cannot deactivate theme because that map functionality is only in houzez theme…..

    Moderator t-p

    (@t-p)

    Akshay,

    – As I said in my previous reply, since that is a commercial theme or plugin, we ask that you please go to their official support channel, so you can get support from the people who know it best.
    – Commercial products are not supported in these forums. As you are their customer; they should not have problem supporting you there.
    – Forum volunteers are also not given access to commercial products, so they would not know why your commercial theme or plugin is not working properly. This is one other reason why volunteers forward you to the commercial product’s vendors. The vendors are responsible for supporting their commercial product.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.