Support » Plugin: Cloudflare » admin-ajax.php and fastcomet webhosting

  • Hi recently discovered that I cannot load the admin pages on any of my sites running on FastComet hosting. I am looking for help in what I should tell them to fix this.

    Going to Settings > Cloudflare just results in an indefinite loading spinner and I never get options.

    Inspecting the browser console I can see an error 500 when loading compiled.js via admin-ajax.php which then results in json errors throughout. My host says they are not blocking anything and responded with a really dumb answer that it was my browser cache/cookies which have nothing to do with error 500.

    Nevertheless, I tested from other machines and browsers.

    The failed resource url is similar to this:

    https://www.mydomain.com/wp-admin/admin-ajax.php?action=cloudflare_proxy&proxyURL=plugin%STRINGDATA%2Fsettings%2F&proxyURLType=PLUGIN

    Any advice?

    • This topic was modified 1 year, 5 months ago by  Philip Ingram.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author thellimist

    (@furkan811)

    Hi,

    What version of the plugin are you using?
    Do you have any PHP errors?

    Version 3.2.1 and no PHP errors in debug log. This is now confirmed. I cannot use this plugin on any Fastcomet hosting plan.

    I’ve logged into multiple customer’s accounts and can’t access any of the settings pages except for the loading spinner. These sites are running different themes and have no relation to each other.

    I’ve discovered that while the url above w/ CF query strings result in error 500 in the console, if I open them up directly in another browser tab I get the full json output as expected but not sure why they load directly but not from within admin.

    Plugin Author jwineman

    (@jwineman)

    Hi @pingram3541,

    If you’re getting a 500 in the browsers console there should be a corresponding error in the PHP error log. Can you either copy it out of the browser dev tools or the PHP error log so we can investigate further?

    Thanks,
    John

    There error is on the first post above and I’m pretty versed in using wp-debug and enabling/checking the log but on this shared hosting environment the server’s php log is inaccessible.

    Browser console, json errors are obvious result of the 500 error (I don’t think these errors provids any help to you because it’s not javascript broken because of code, it’s broke because the server didn’t send the file)

    /wp-admin/admin-ajax.php?since=-43200&action=cloudflare_proxy&proxyURL=zone…blahblah%2Fanalytics%2Fdashboard&proxyURLType=CLIENT Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    /wp-admin/options-general.php?page=cloudflare#/home:1 Uncaught SyntaxError: Unexpected token < in JSON at position 0
        at JSON.parse (<anonymous>)
        at Object.callback (compiled.js:6)
        at compiled.js:49
        at Request.callback (compiled.js:49)
        at Request.<anonymous> (compiled.js:49)
        at Request.Emitter.emit (compiled.js:49)
        at XMLHttpRequest.xhr.onreadystatechange (compiled.js:49)
    
    /wp-admin/admin-ajax.php?action=cloudflare_proxy&proxyURL=zones...dns_records&proxyURLType=CLIENT Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    
    /wp-admin/options-general.php?page=cloudflare#/home:1 Uncaught SyntaxError: Unexpected token < in JSON at position 0
        at JSON.parse (<anonymous>)
        at Object.callback (compiled.js:6)
        at compiled.js:49
        at Request.callback (compiled.js:49)
        at Request.<anonymous> (compiled.js:49)
        at Request.Emitter.emit (compiled.js:49)
        at XMLHttpRequest.xhr.onreadystatechange (compiled.js:49)
    
    /wp-admin/admin-ajax.php?action=cloudflare_proxy&proxyURL=plugin%2blahblah%2Fsettings%2F&proxyURLType=PLUGIN Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    
    /wp-admin/options-general.php?page=cloudflare#/home:1 Uncaught SyntaxError: Unexpected token < in JSON at position 0
        at JSON.parse (<anonymous>)
        at Object.callback (compiled.js:6)
        at compiled.js:49
        at Request.callback (compiled.js:49)
        at Request.<anonymous> (compiled.js:49)
        at Request.Emitter.emit (compiled.js:49)
        at XMLHttpRequest.xhr.onreadystatechange (compiled.js:49)
    
    /wp-admin/admin-ajax.php?action=cloudflare_proxy&proxyURL=zones%2Fblahblah%2Fsettings&proxyURLType=CLIENT Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    
    /wp-admin/options-general.php?page=cloudflare#/home:1 Uncaught SyntaxError: Unexpected token < in JSON at position 0
        at JSON.parse (<anonymous>)
        at Object.callback (compiled.js:6)
        at compiled.js:49
        at Request.callback (compiled.js:49)
        at Request.<anonymous> (compiled.js:49)
        at Request.Emitter.emit (compiled.js:49)
        at XMLHttpRequest.xhr.onreadystatechange (compiled.js:49)
    Plugin Author jwineman

    (@jwineman)

    Unfortunately without the stack trace that is causing the 500 we aren’t going to be able to debug further. Would you be able to ask your host for a sample 500 error log?

    Thanks,
    John

    Plugin Author jwineman

    (@jwineman)

    If you go into the “Network” tab in dev tools, click on the request that is 500ing and then click on “Response” you should see the full error page being returned. That response should have more detailed information about what went wrong. Can you post one of those please?

    I’ll need a way to PM you please. Stuff in there not for public eyes…

    Plugin Author jwineman

    (@jwineman)

    No worries! Can you please open a support ticket on https://support.cloudflare.com and include a link to this page, the 500 response, and ask the support engineer to assign the JIRA ticket to me.

    Thanks,
    John

    I updated the ticket today. The host never provided the logs and the problem seemed to simply fix itself after a couple back and forth chats within the hosts ticketing system.

    After some poking around I realized they simply disabled mod_security which is not a long term solution but I confirmed that enabling it again breaks the plugin, *among others* (adminer, string locator, wordfence scans…).

    I will just have to remember to disable/enable mod_security when using this plugin + hosting company as it seems the host does not want to take this any further unfortunately.

    Kind of ruins the convenience factor though.

    Either case, thank you for providing this great service and plugin, cheers!

    Plugin Author jwineman

    (@jwineman)

    Hi,

    Thanks for the update! If you open another support ticket there might be a known solution for the mod_security issue.

    Thanks,
    John

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘admin-ajax.php and fastcomet webhosting’ is closed to new replies.