Support » Plugin: Elementor Website Builder » admin-ajax.php

  • Resolved wongpk

    (@wongpk)


    I tried to import a library template, it stopped at admin-ajax.php on error 500.

    I increased the memory to 512mb and deactivate all plugins, it’s still going to the same issue with admin-ajax.php. Even reinstall WordPress still having the same issue.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @wongpk

    Does your hosting service have mod_security enabled?

    It could be server limits are being reached. Error 5XX should also show up in the server logs with more detail as to the source. i.e. permissions, memory

    Thread Starter wongpk

    (@wongpk)

    Hi @pingram3541,

    But previously it works, after the update it doesn’t anymore.

    I checked error_log from cPanel, but nothing shows up regarding the ajax.

    I’m with share hosting so my error log may be limited. Do you have any suggestion as to where can I work around it anymore?

    Thanks!

    You may have to reach out to your hosting company because the server error_log should show that exact 500 error.

    Other things I’ve had to do is go into cpanel php version and often there is a way to toggle into advanced options of which you can increase PHP memory and post maximums. It could be you’re hitting a maximum on the length (time) or query qty (# of queries at once) or even hitting a maximum on the memory allowed per single post size. I’ve seen default post size @ 2MB which often effects large imports.

    I’m thinking that is likely where you might be able to also verify you have access to 512M or more of actual PHP memory allocated to the system. Often I have to increase my PHP memory limits in cpanel before I can increase the memory defined in wp-config.php

    Also, when you say previously it works, are you still referring to importing the exact same template? Is it only the import function that breaks? Can you try to import something basic, like a single section with basic text…something small just to see if it’s the mechanism itself or the size of the import the causes the issue.

    Thread Starter wongpk

    (@wongpk)

    @pingram3541,

    Thanks for the info.

    Not the same template, however the file is just 64KB+/-.

    Maybe the hosting issue, as I tried another host, it works just fine. Only this exact host (2 WordPress sites) can’t import and has the exact same issue.

    Will check on PHP increase before wp-config limit.

    Thanks for the head up and your time, appreciate it.

    Np, best of luck. If you do figure it out, please post back, maybe someone else could benefit. Cheers.

    Thread Starter wongpk

    (@wongpk)

    Hi @pingram3541,

    I found out that I did not install the zip extension on PHP 7.1.

    It’s working now after I add the extension.

    Thanks for your time.

    • This reply was modified 3 years, 9 months ago by wongpk.

    Glad you got it figured out and thanks for sharing your solution! Makes sense too as they recently added a feature to upload multiple templates via zip vs just a single json file.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘admin-ajax.php’ is closed to new replies.