Support » Plugin: LiteSpeed Cache » Receive 404 when try save settings

  • Resolved Ivan Borisov

    (@borisov87)


    Receive error 404 when try to save changes in settings
    https://goo.gl/photos/RS5Z8fcnYvJaF6MMA

    Server Variables
    SERVER_SOFTWARE = LiteSpeed
    DOCUMENT_ROOT = /home2/ltumkofx/tortieliza.com
    X-LSCACHE = 1

    LSCache Plugin Options
    version = 1.0.14.1
    enabled = 1
    radio_select = 1
    purge_upgrade = 1
    cache_commenters = 1
    cache_login = 1
    cache_favicon = 1
    cache_resources = 1
    mobileview_enabled =
    mobileview_rules =
    login_cookie =
    tag_prefix =
    check_advancedcache = 1
    debug = 0
    admin_ips = 127.0.0.1
    test_ips =
    public_ttl = 28800
    front_page_ttl = 1800
    feed_ttl = 0
    403_ttl = 3600
    404_ttl = 3600
    500_ttl = 3600
    nocache_vars =
    nocache_path =
    purge_by_post = A.F.H.M.PT.T
    excludes_uri =
    excludes_cat =
    excludes_tag =
    nocache_cookies =
    nocache_useragents =
    wc_update_interval = 0
    wc_shop_use_front_ttl = wc_shop_use_front_ttl

    WordPress Specific Extras
    wordpress version = 4.7.2
    locale = bg_BG
    active theme = Caliber
    active plugins = Array
    (
    [0] => akismet/akismet.php
    [1] => ank-google-map/ank-google-map.php
    [2] => autodescription/autodescription.php
    [3] => ewww-image-optimizer/ewww-image-optimizer.php
    [4] => jetpack/jetpack.php
    [5] => litespeed-cache/litespeed-cache.php
    [6] => live-editor/live-editor.php
    [7] => my-custom-functions/my-custom-functions.php
    [8] => schema/schema.php
    [9] => simple-image-sizes/simple_image_sizes.php
    [10] => static_content_blocks/content-blocks.php
    [11] => woocommerce/woocommerce.php
    [12] => wp-simple-booking-calendar/wp-simple-booking-calendar.php
    [13] => wp-sweep/wp-sweep.php
    )

    /home/ltumkofx/tortieliza.com/.htaccess contents:
    RewriteEngine On
    RewriteRule .* – [E=Cache-Control:no-cache]

    <IfModule LiteSpeed>
    ###LSCACHE START PLUGIN – Do not edit the contents of this block!###
    RewriteEngine on
    CacheLookup Public on

    ###LSCACHE START RESOURCE###
    RewriteRule wp-content/.*/[^/]*(loader|fonts|\.css|\.js)\.php – [E=cache-control:max-age=3600]
    ###LSCACHE END RESOURCE###
    ###LSCACHE START FAVICON###
    RewriteRule favicon\.ico$ – [E=cache-control:max-age=86400]
    ###LSCACHE END FAVICON###
    ###LSCACHE END PLUGIN – Do not edit the contents of this block!###
    </IfModule>
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    • This topic was modified 4 years, 1 month ago by Ivan Borisov.
    • This topic was modified 4 years, 1 month ago by Ivan Borisov.
    • This topic was modified 4 years, 1 month ago by Ivan Borisov.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author LiteSpeed Technologies

    (@litespeedtech)

    Hi @borisov87

    We’d like you to check something. In your browser, open the inspector (ctrl+shift+i), then go to our settings page. Do any javascript errors pop up?

    Thanks,
    Kevin

    Thread Starter Ivan Borisov

    (@borisov87)

    Ok i test with all plugins disabled and see no problem save settings work. Also i test step by step enable plugin and problem arive only with
    https://bg.wordpress.org/plugins/jetpack/
    enabled.
    Also i test only LiteSpeed Cache and Jetpack enabled, and problem continue. With all plugins enabled and only jetpack disabled – no problem and errors. So
    LiteSpeed Cache have some conflict with Jetpack by WordPress.com

    • This reply was modified 4 years, 1 month ago by Ivan Borisov.
    Plugin Author LiteSpeed Technologies

    (@litespeedtech)

    Thanks for the useful tip!

    What settings do you have enabled in jetpack so we can try to replicate the environment?

    Thread Starter Ivan Borisov

    (@borisov87)

    I try with browser console and see this in console
    JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate.min.js:2:542
    SyntaxError: illegal character admin.php&tab=4&tab=2:158:30

    Thread Starter Ivan Borisov

    (@borisov87)

    i see does not matter settings, i try with different tabs and different setings and not work when jetpack is enabled

    Plugin Author LiteSpeed Technologies

    (@litespeedtech)

    Thanks for the tips! We’ll look into this and get back to you when we find something.

    Plugin Support Hai Zheng⚡

    (@hailite)

    @borisov87 Can you remove litespeed-cache/admin/js/litespeed-cache-admin.js line 51 $("form").attr("action", new_url);
    temporarily to fix the compatibility?

    This way after you save the settings, you have to switch to the current tab manually. But saving should work.

    Will fix this compatibility in next version. Thanks for your report.

    • This reply was modified 4 years, 1 month ago by Hai Zheng⚡.
    • This reply was modified 4 years, 1 month ago by Hai Zheng⚡.
    Thread Starter Ivan Borisov

    (@borisov87)

    Yes i test with this fix, and work :). Thanks

    Plugin Support Hai Zheng⚡

    (@hailite)

    You are most welcome. Enjoy LiteSpeed

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Receive 404 when try save settings’ is closed to new replies.