Support » Theme: Sydney » Adjustment breakpoint mobile menu no longer working

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter humpiedump

    (@humpiedump)

    Forgot to mention: the menu has dissapaered between 767px and 1024 px screenwidth 🙂

    Hi,

    We have updated the main Sydney theme’s script since version 1.72. So you have to do some adjustments due this change. Try these steps:

    1. Copy the code js/functions.js from main theme’s folder (sydney);
    2. and paste it into your child theme’s script (js/sydney-main-child.js) to replacec the entire code.
    3. While you still in the js/sydney-main-child.js code editor, find this line of code:
    4. 
      if ( window.matchMedia( "(max-width: 1024px)" ).matches ) {
      

      and replace it with:

      
      if ( window.matchMedia( "(max-width: 767px)" ).matches ) {
      
    5. Update this file change to your website via FTP/sFTP program
    6. Clear cache and reload your website

    I request you give it a try and let me know your views.

    Regards,
    Kharis

    Thread Starter humpiedump

    (@humpiedump)

    Hello Kharis,

    Thanks for your quick response. I did as you suggested. unfortunately the outcome is the same as you can see. I have cleared the cache in wordpress and browser.

    Is this code in childthemes function.php still correct?:

    /* Aangepaste enqueue voor child-theme-java (aanpassingbreekpunt)*/
    
    function sydney_child_dequeue_script() {
       wp_dequeue_script('sydney-main');
    }
    add_action( 'wp_print_scripts', 'sydney_child_dequeue_script', 100 );
    
    function add_theme_scripts() {
      wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' );
     
      wp_enqueue_script( 'sydney-main-child', get_stylesheet_directory_uri() . '/js/sydney-main-child.js', array('jquery'),'', true );
    }
    add_action( 'wp_enqueue_scripts', 'add_theme_scripts' );

    Best regards,
    Bernhard

    Hi Bernhard,

    Replace this line in your child theme’s functions.php:

    
    wp_dequeue_script('sydney-main');
    

    with:

    
    wp_dequeue_script('sydney-functions');
    

    Then do the steps I’ve mentioned in this thread.

    Regards,
    Kharis

    Thread Starter humpiedump

    (@humpiedump)

    Hello Kharis,

    Works, problem solved.
    Thank you for your support!

    Best regards,
    Bernhard

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Adjustment breakpoint mobile menu no longer working’ is closed to new replies.