Support » Fixing WordPress » Adjust Thumbnail Image

  • My blog theme has an image slider that takes wide images, but uses a square thumbnail for the featured image. Maybe this is a theme thing, but WORDPRESS has the feature to edit the thumbnail.

    If I click Set Featured Image > Gallery > and click “show” next to the desired image > Edit Image and then it shows the image and the thumbnail.

    The Thumbnail was a square cropped out of the middle of the image which does not look good in many cases.

    From the Edit Image area:
    “The thumbnail image can be cropped differently. For example it can be square or contain only a portion of the original image to showcase it better. Here you can select whether to apply changes to all image sizes or make the thumbnail different.”

    Well, no it can’t. I crop out the part of the image and click Thumbnail under “apply changes to” (and even if I apply to all versions or all but the thumbnail – nada)

    Basically it seems the save button is just broken because nothing happens. I have tried many ways of searching both Google and this forum and have many results but nothing that describes this exactly and so…

    here I am. Am I alone? Is this a bug?

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Thanks for the reply. I don’t want to do all of that to my Website so here is what I did. I have a test WordPress site that I use from time to time for working out themes and plugin functionality prior for use on my live site. Over there there are no avtive plugins and only the two that come with are installed and I switched to the Twenty Eleven theme.

    I did not try the last one as I don’t think it is necessary but I will if you still feel it is.

    It didn’t resolve anything. So this must be either a bug in WordPress or an issue with WordPress on this environment.

    It is my own dedicated server with CentOS and WHM/cPanel. Here is the PHP info output:



    Forum Moderator

    I don’t want to do all of that to my Website

    This is part of the initial troubleshooting process. If you can’t help us, we can’t help you.

    Okay, but the test site that I mention in my reply has all of the same conditions and is exactly the way you requested

    • Theme Twenty Eleven
    • No additional plugins installed
    • No plugins enabled (Akismet and Hello Dolly)
    • The active_plugins was already set to “a:0:{}” (but I reset t anyway)

    Again, all but that last step was already done, and on this site I still have the same behavior. Now everything you requested is done and I still cannot change the thumbnail.n

    Given that this behavior persists on three of my WordPress sites all on the same server is it logical to point to one of the following?

    • A bug in WordPress
    • Something characteristic with the hosting evironment


    Forum Moderator

    This is part of the initial troubleshooting process. If you can’t help us, we can’t help you.

    I did everything you asked. What is wrong with you?

    Just in case I am misunderstanding you, and in an attempt to do everything that you asked, I removed even the default plugins, and did the reset again (changing it to the same value t already is really).

    Still the thumbnail changer fails to allow me to make the change.

    Am I the only one this happens to? Is esmi the only one there?

    Heck, can give you access to the site, I can even completely delete it and do a clean WP install if you want. The problem will still persist and you can see for yourself.

    OMG! Nevermind. I didin’t realize I had to mark the crop area and then hit the crop button again. I assumed I just hit SAVE.

    Save was doing nothing, but that is because I never actually cropped the image. Not exactly intuitive. There is lots of helpful information on this edit image box, but this explanation was missing and might be worth noting.

    I hope this helps someone else. And I hope someone can help esmi. I think I understand the nature of what he was asking, but poorly done really.

    I love WordPress. I am glad there is support here. Perhaps I will just have to withhold some details the next time I am looking for help.

    This helped me, thanks smileybri. I think this is a UX bug – My first instinct was to just hit SAVE as well. It’s not clear that you have to hit the crop button again.

    Thanks, this helped me a lot. I was having the exact same problem and didn’t want to have to uninstall all plugins. Thanks for helping me realize I wasn’t understanding the UI.

    But where is the crop button?

    I’m having the same problem, save does nothing…but I ain’t got no crop button.

    Help much appreciated.

    It is under the Update Media button and above the image. The first button on the toolbar (left).

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Adjust Thumbnail Image’ is closed to new replies.