WordPress.org

Support

Support » Plugins and Hacks » ADI not working after ADI 1.1 and WP 3.1.2 Update

ADI not working after ADI 1.1 and WP 3.1.2 Update

  • patrickhjohnson
    Member

    @patrickhjohnson

    After upgrade both the ADI Plugin to 1.1 and WP to 3.1.2 I can no longer authenticate AD users. I performed the upgrade on our development server. I check and copied settings from production for ADI, which is still working in production on WP 3.1.1 and ADI 1.0. We had been using the bind user, but that option is gone. I rolled ADI back to 1.0 with WP 3.1.2 and tried again but still no luck. The test tool gives the following output:

    AD Integration Logon Test

    openLDAP installed

    [INFO] method authenticate() called
    [INFO] ——————————————
    PHP version: 5.3.4
    WP version: 3.1.2
    ADI version: 1.1
    OS Info : Darwin removed 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 15:16:10 PST 2011; root:xnu-1504.9.37~1/RELEASE_X86_64 x86_64
    Web Server : apache2handler
    adLDAP ver.: 3.3.2 Extended (201104081456)
    ——————————————
    [NOTICE] username: removed
    [NOTICE] password: **not shown**
    [INFO] Options for adLDAP connection:
    – account_suffix: @removed
    – base_dn: dc=removed,dc=removed,dc=removed
    – domain_controllers: removed
    – ad_port: 389
    – use_tls: 1
    – network timeout: 5
    [NOTICE] adLDAP object created.
    [INFO] max_login_attempts: 3
    [INFO] users failed logins: 0
    [NOTICE] trying account suffix “@removed
    [ERROR] Authentication failed

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘ADI not working after ADI 1.1 and WP 3.1.2 Update’ is closed to new replies.