WordPress.org

Support

Support » How-To and Troubleshooting » Adhesive plugin not working

Adhesive plugin not working

  • Hi,
    Site: http://www.os42.com
    I have added the Adhesive plugin [from http://www.asymptomatic.net] to my site. It has been activated and it shows a ‘sticky’ checkbox but it doesn’t appear to be working as it should. I have tried to make one particular post a sticky but it just isn’t happening.
    Running on 1.2 Mingus.
    Any one else had this problem or know what I may be doing wrong?
    Thanks for any advice suggested 🙂

Viewing 15 replies - 1 through 15 (of 33 total)
  • I’m having the same problem.. I’m not sure where to look to find out what might be wrong.
    If I go to edit the post, the sticky flag is gone. If i check it, and save, it’s there… but goes away as soon as I leave to another page.

    exact same problem here. looked through the code and could not quickly dicern what needs to be adjusted/changed. any ideas?

    Anonymous

    Same here… has anyone found anything? I tried the latest version even.

    philpeeps

    @philpeeps

    same here….help!

    Hmm?

    Anyone seen this when using Adhesive. I must say I like the plugin very much but when I click on any category I get the following error message at the top of the blog….

    </style><div id=’error’>
    Database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘ON (Adhesive.Post_ID = .post_id) WHERE 1 AND (category_id = 1]
    SELECT *, ID as Post_ID FROM Adhesive LEFT JOIN ON (Adhesive.Post_ID = .post_id) WHERE 1 AND (category_id = 1);

    Pulled this out of the web page source as it was a bit cut off.

    Anyone seen this one before??

    Never mind.

    Upgrading the plug in to 1.6 alpha fixed my SQL issue.

    There appears to be no way to get this plug-in to work. No one I’ve spoken with has had any luck with it.

    If someone has some ideas, please post them. A lot of us would love such a plug-in provided it worked.

    Has anyone contacted the plugin author?

    I am having trouble too. One blog, on WP 1.2.1 does show the sticky checkbox, but when i then go to view site, i get a big fat DB error on top (and i am the site admin and have all the database rights)

    on a second blog, which is 1.2.2 simply nothing happens, no sticky check box, no errors.

    I have tried to contact Owen, the author, via email and comment on his website, no reply yet. But I guess he is busy.

    I tried to look for alternatives, but the only one i found again directed me to Owen’s website .. that must have been a different name he used initially for the plugin

    I too have attempted to install just about every version of sticky over WP 1.2.2, and none actually create the “Sticky”checkbox. There is no obvious location to send bug reports.

    My copy was installed by webapp-config under Gentoo.

    Same issue for me. I tried Adhesive 2.1 and 1.6 and 1.5 and none of them created the Sticky box.
    Oh well.. it would be nice. but then again.. In my own personal blog, how often do I really need something to be seen day after day?

    I use adhesive 2.1 beta on WP 1.5, found it easy to install and it work. So it does work on WP 1.5 at least.

    Will just need to style it now.

    2.1 beta works great on one website for me.
    But on another, I can’t get the Sticky box to appear.
    Running wp 1.5.1.1 on both.
    There’s something going on in there that makes no sense to me.

    It’s not working in WP 1.5.1.2 either. I don’t get the checkbox at all. It’s being completely ignored by the add_filter routine.

    This is such a useful thing – is it possible to integrate it into the core code? I realize that may be asking a lot.

    The sticky box was not showing up for me either I am running 1.5.1.2 and here is what I did to fix it. Kind of simple, but in the admin panel under options->writing-> then the first question “when starting a post show:” I had it set to advanced controls. I changed it back to simple controls, then deactivated the plugin, then reactivated it. Then I went and wrote my post and clicked on the advanced controls tab and what do you know, there is the sticky box.
    Hope this helps someone.
    -Ben

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Adhesive plugin not working’ is closed to new replies.
Skip to toolbar