Support » Plugins and Hacks » Adhesive Plugin Has Problems with WordPress 2.1

Adhesive Plugin Has Problems with WordPress 2.1

  • Even though Adhesive Plugin is listed as compatible, their are problems with WordPress 2.1. When activated the Previous/Next navigation no longer works on my blog. I had to disable it. I tried the Codex for the correct code for my theme and it is correct. I also read on this support forum others with this problem.

    Any ideas? I guess I will have to hope for an updated “sticky” plugin. Does anyone know of a similar plugin I can try for WordPress 2.1?

    Thanks in advance.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Do you have Adhesive v3.2?
    Mine works fine on the test site I have with 2.1.

    Yes I am running Adhesive 3.2, WordPress 2.1, on the Tiga theme.

    It broke many of my sites, so I deactivated it, and did the sticky.php page as vkaryl wrote about as an alternative, and it works. I like it better, since I won’t have to worry about a plugin any longer

    Adhesive 3.2 won’t load in 2.1 for me. It completely wipes out the plug-ins page in the administration panel. The author’s blog has been under construction/repair for quite awhile and doesn’t seem to have a place to leave a message. Hoping he’ll see one of these threads and address the issue…

    I’m experiencing the same problem as Servant: Adhesive 3.2 blanks out the plugins admin page in WordPress 2.1, but the plugin seems functional otherwise. However, I am also noticing this in WordPress 2.0 on a machine running PHP 5.2.0, whereas it was working a machine running PHP 5.0.4. The two PHP installations are fairly different aside from version, but maybe this has something to do with it.

    On trying to load plugins.php, the following line shows up in the PHP error log:

    PHP Fatal error: Call to a member function get() on a non-object in /path/to/wp-includes/cache.php on line 29

    And what about changing the date and time of the post to the future in order to stay on top? It works with 2.0.7 (not tested with 2.1).

    My web host has just upgraded to PHP 5.2.1 and now Adhesive 3.2 with WP 2.0.7 got the same problem. And I’ve found the reason. When activated, Adhesive proposes its options below the “Desactivate” link. This is breaking the page now. I’ve desactivated it (by changing its name with a ftp client), and reactivated it, and the plugins page is now fine. The only difference, I cannot access to the Adhesive options anymore.

    The problem is coming from line 268 to 276, a preg_replace_callback function. If someone can see what’s wrong, we will be able to edit it.

    or can someone suggest an alternative?

    a linky to an alternative would be helpful 🙂

    Damn… this is a dead end. The issue described above with the plugin page issue is spot on, however I cannot seem to find neither a solution (fix) for the Adhersive plugin nor any usefull alternative. tried searching virtually everywhere…

    Anybody any suggestions or a bugfix for WP 2.1… I’d be soooo happy! 🙂

    I have forked out Adhesive to be called WP-Sticky.


    It work with WP 2.1.1, PHP 5.20 and MYSQL 5.

    It is now still losely based on Adhesive

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Adhesive Plugin Has Problems with WordPress 2.1’ is closed to new replies.