Support » Plugin: PixelYourSite - Your smart PIXEL (TAG) Manager » AddToCart doesn’t send correct variant ID on product page

  • Resolved Sphinxxxx

    (@sphinxxxx)


    On a (WooCommerce) product with variants, when you select a variant on the Product page and click “Add to cart”, Facebook Pixel helper gives a warning on the AddToCart event, saying “Can’t match products”:

    https://imgur.com/a/7vS4T

    If you then go to view the Cart, the AddToCart event now works:

    https://imgur.com/a/ZzpyB

    The difference is the submitted content_ids: On the Product page, the ID on the product itself is submitted, and on the Cart page, the specific variant’s ID is submitted. So it looks like the AddToCart event expects a variant ID in this case, and that’s what should be submitted on the Product page as well?

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author PixelYourSite

    (@pixelyoursite)

    There are two way to deal with this situation:

    1. Include all variations in your Product Catalog.

    2. Treat variable products like simple product: open PixelYourSite WooCommerce tab and you’ll see this option there.

    • This reply was modified 2 years, 6 months ago by PixelYourSite.

    Thanks, but I think you misunderstand; I do have all variations in the catalog, and I need the specific variant ID to be submitted, which it wasn’t.

    However, your second point lead me to the answer:

    We have the Use Facebook for WooCommerce extension content_id logic option checked, so the “simple products” option wasn’t visible. I changed it to PixelYourSite content_id logic and then *un*checked the “simple products” option, and then changed back to Use Facebook for WooCommerce extension content_id logic.

    ..And now it works. But that looks like a bug, right? In Use Facebook for WooCommerce extension content_id logic mode, the “simple products” checkmark should probably be ignored in the event handling from the Product page?

    Plugin Author PixelYourSite

    (@pixelyoursite)

    It’s a sort of a bug, meaning that you can’t revert back to the original config while Fb for WooCommerce mode is enabled.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘AddToCart doesn’t send correct variant ID on product page’ is closed to new replies.