Support » Plugin: AddToAny Share Buttons » addtoany asynchronous code causing issues

  • I tried the plug recently, but dont’ want a standard configuration anywhere. I unchecked all the boxes for placement, and created a custom div to stack share and 2 stadalones in teasers. That part worked fine… except it slowed my site to an unacceptable crawl.

    I would have assumed that asynchronous loading would be default behavior. I cant think why someone wouldn’t want that, but I’m a noob, so… I see on the site code for creating async loading.

    It doesnt say WHERE to put the code, though. Since I’m using Thesis, and they always say to put everything in custom_functions_php, that’s what I did. I had to put a ?> at the beginning and <?php at the end to get it to take, but that seemed to do the trick.

    And… the load time is MUCH better… but everything else went haywire.

    A share button suddenly appears in the upper left of every page, and won’t go away. When I click on the share buttons, I see that they’ve lost all custom formatting, url titles, etc… they’re generic windows.

    I’m not sure what to do here. I just can’t use the plug at all without the async loading, but not sure how to fix this.

    I should mention that the instructions say something about placing the code:

    Now, I can’t even get into my wp admin panel as it’s causing the following message:

    Warning: Cannot modify header information – headers already sent by (output started at /home/greg/public_html/wp-content/themes/thesis_182/custom/custom_functions.php:266) in /home/greg/public_html/wp-includes/pluggable.php on line 934

    Was this not supposed to go in custom_funtions_php? What am I doing wrong here? Just want buttons to load after page.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Ok, back and forth with thesis mods. I have it installed correctly now in thesis design options/javascript/embedded scripts. I’ve gone through and disabled every single plugin that could even potentially have any conflict.

    I’ve removed jquery slider. I’ve triple-checked that there’s no other embedded script anywhere. There is zero javascript in my custom_functions_php file (the only place in the theme that I make php alterations)

    Still, the code breaks the button. The two standalone buttons work, but the share button loses all connection with thesite, does nothing on hover, and goes to upon click.

    I’ve tried ditching my custom div and just using standard button placement. I’ve tried ditching button and using custom button.

    It seems that something about embedding the code is causing the button to break.

    Plugin Author micropat


    AddToAny is already loaded asynchronously via the plugin. There is no need to use the general asynchronous code from, so you should definitely remove the code that you tried to integrate.

    If you’re using the standalone Like, Tweet, or +1 buttons, there is still some optimization work to be done for those. You’ll see faster load times for these specific buttons in a future update. All the other standalones will load faster (i.e. regular Facebook & Twitter).

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘addtoany asynchronous code causing issues’ is closed to new replies.