Support » Plugin: Share Buttons by AddThis » Addthis widget buttons inactive with WP3.6

  • In the AddThis widget added to a page top section, the short strip button bar is displayed but does not activate when hovered over. The larger button bars do not display at all. This worked with the previous version of WordPress and the theme generated by Artisteer I am using.
    The website is current in development,so hidden from view.
    Also, the button bars do not appear at the top or bottom of posts as set in the AdThis settings panel.
    Is there a fix for this please?

    I have found part of the problem: if I disable the WordPress SEO by Yoast plugin, AddThis starts working again.

    Still not sure what is route cause though, as other plugins are working as expected.

Viewing 12 replies - 1 through 12 (of 12 total)
  • @lencw: Can I have a url for the development site? If it’s not ready for public, please send it to srijith[AT]]

    We have checked in WP3.6 and is working fine. May be a conflict with SEO plugin, or the theme.

    Will send a separate email with details.

    The WordPress search function crashes out with the following error message. This time it happens if the SEO plugin is activated or deactivated.

    var addthis_config = {“data_track_clickback”:false,”data_track_addressbar”:false,”data_track_textcopy”:false,”ui_atversion”:”300″}; var addthis_product = ‘wpp-3.1’; …

    I have tried with my theme and with TwentyThirteen, same with both, so this sort of suggests the themes are not involved.

    I’m having the same problem, when WordPress SEO by Yoast plugin the buttons aren’t rendered.

    I’m debugging now to see if i can pinpoint the problem in a accurate form.

    We are checking on it. Will get back to you as soon as possible.

    I’ve done some testing and I’ve noticed that none of the AddThis js are loaded once the SEO is active. I haven’t been able to figure out why.

    Thanks for any help in this matter.

    I am having the same problem. It was working up until this morning when I updated the plugin. Now I don’t see anything.
    I have WordPress SEO by Yoast too.

    Thanks for your help.


    We think we found the reason why the buttons didn’t show up.

    We have two environments, one develop and one production. The buttons are visible on develop, but not on production.

    Debugging the code, we found that on the page where the buttons didn’t show up, the “output_script_filter” function was called twice. Once with of course the $this->_js_added == false, and once with the $this->_js_added == true.

    This filter is set on the_content. The connection with the WordPress SEO is with the “the_content_feed” filter, which also calls all the “the_content” filters. So the addthis variant of the the_content filter is also called in this stage and the $this->_js_added variable is set to true in a stage too early.

    Although this shows the relation between the plugins, it isn’t explanation of the difference between both environments.

    We traced this bit of the problem back to the addthis option “wpfooter”, being boolean=1 on the develop environment, but being null on the production environment. Both values of course being set in the JSON stored field in the wp-options table.

    The former paragraph can also be used as a preliminary work-around for the problem.

    With regards,
    Timo van den Bos, Mark Roeling
    [sig moderated as per the Forum Rules]

    There’s useful further analysis here:

    For now, the “workaround” is to disable the FB open graph meta data options on the Social panel in Yoast SEO.

    For the record, my symptoms were on a page where I specifically exclude AddThis and my Exec-PHP code was no longer being executed…

    Same problem happened to me, same workaround applied (thank you Andy!):

    “For now, the “workaround” is to disable the FB open graph meta data options on the Social panel in Yoast SEO.”

    We are trying to make it compatible with Yoast, and will be updated here.

    Unchecking all Clean up the <head> in Yoast SEO worked for me

    @srijith .. same problem, and same workaround from Andy work for me. But after 8 months I do not see any updates yet. Better to look for other plugins?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Addthis widget buttons inactive with WP3.6’ is closed to new replies.