WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Addthis Not Displaying On Pages Where eshop code is used

[Resolved] Addthis Not Displaying On Pages Where eshop code is used

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi
    Forum Moderator

    @esmi

    Can you replicate the problem using the Twenty Eleven theme with all other plugins deactivated?

    neverthebride
    Member

    @neverthebride

    Yes, problem replicates with only addthis and eshop plugins active. Screenshots in Twenty Eleven with same page examples as earlier here: http://www.neverthebride.com/addthis.zip

    Thanks for the quick reply! 🙂

    esmi
    Forum Moderator

    @esmi

    We’ve checked at our end and there is nothing in eShop that should cause such an issue. We’ve also not had any other reports of a problem with the AddThis plugin. The only thing we can do atm is to add it to the list of reported incompatible plugins.

    esmi
    Forum Moderator

    @esmi

    As there has not been an update to this topic for a while, I can only assume that the issue has now been resolved and I am now marking it as such. If this is incorrect, please feel free to change the topic’s status and/or post a followup.

    neverthebride
    Member

    @neverthebride

    Sorry to report that we are still having this problem, sharing buttons show fine on all pages except those where the manual ehop shortcode has been added.

    In order to try and resolve the problem, I removed AddThis and tried AddToAny instead. In this case, on pages where the shortcode was used, the sharing button ended up in the eshop area and not at the end of the page like it does on pages where there is no eshop shortcode. So the problem doesn’t appear unique to AddThis but also to AddToAny as well!

    Is there any solution to this problem? Even if I could enter the AddThis manually on the affected pages would be a help.

    many thanks

    esmi
    Forum Moderator

    @esmi

    eShop has nothing to do with any Add This plugin.

    neverthebride
    Member

    @neverthebride

    Thanks for the reply. Does adding the manual shortcode to another page cause some change in the page that may result in AddThis not displaying? Since it also happens with other sharing plugin AddToAny and removing the shortcode results in the sharing buttons re-appearing, I have had to conclude that eshop must somehow be the root of this issue.

    On pages without the shortcode I can see in the page properties “<!– AddThis Button BEGIN –>” but when the shortcode for another product is in use this simply doesn’t appear.

    Is there a way of adding the AddThis back in manually to pages using the shortcode?

    neverthebride
    Member

    @neverthebride

    PS. http://wordpress.org/support/topic/addthis-buttons-not-showing-on-two-specific-pages – this appears to be a very similar issue occurring.

    esmi
    Forum Moderator

    @esmi

    Does adding the manual shortcode to another page cause some change in the page that may result in AddThis not displaying?

    It shouldn’t do. eShop uses the Shortcode API amd should co-exist quite happily with other plugins written according to WPORG best practices.

    Is there a way of adding the AddThis back in manually to pages using the shortcode?

    You need to ask the developers of AddThis about that. I don’t know that plugin well enough.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Addthis Not Displaying On Pages Where eshop code is used’ is closed to new replies.