Support » Plugin: Share Buttons by AddThis » AddThis buttons not showing on two specific pages

  • Hello! I’m using the version 3.1 of the plugin. The code that is supposed to go before and after the post/page shows perfectly well, except for two pages, in which for some reason it doesn’t appear at all. I’ve tried checking that the “Remove AddThis” is unchecked, that there are no differences compared to any other page that do have them, that the AddThis settings are ok… But I just can’t figure out why it happens only on those two pages. Has anyone experienced the same problems?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Contributor Srijith V


    @soret: Can I see the page with the issue? There might be a conflict with some features of theme which you are using in that page. I will have a look at let you know.

    Sure thing! It’s not yet finished, so please don’t mind the design! 😉

    Here are the two page that do not show the buttons, as well as their subpages. This is one, and this is another. Notice how every other single page and post shows them (except for the home, but I set it up that way). I even have the AddThis Follow on the header, and that works flawlessly too.

    Thank you so much for your time!

    Hello again! I’ve been thinking this issue through… And I think i may know what is causing it, although I still don’t know how to fix it.

    Do you know the Posts for Page plugin? It’s a plugin that uses a shortcode to show posts from a specific category, basically. The only pages that use this shortcode are the ones that do not show the AddThis buttons. Here’s the list:


    All these pages have a list in them which only shows the excerpts of posts, and not much more. These posts have the AddThis buttons, it’s the pages that contain them that don’t. Could this be causing any type of conflicht?

    Hello again! The problem still persists. The addthis buttons do not want to show on the pages that have Posts For Page shortcodes. However, I tried manually pasting the code that should be generated, and that way it will show them… Should I recur to this?

    Thanks again for your time!

    Plugin Contributor Srijith V


    @soret: Let me check this again. If you have a test site or if you can provide access to admin site, kindly send info to srijith[AT]


    I am experiencing the exact shame issue. AddThis does not show in my Home Page / All posts page. It works in every other page though.

    Would you please help me resolve this issue. Here is a link to my site:

    Also you can reply to this message to: info[AT]

    Thank you!

    Plugin Contributor Srijith V


    Please try enabling “Show on excerpts” option and check if AddThis is working on those pages. The mentioned pages seems to be printing excerpts and that’s the reason why AddThis is not working.

    I have tried that some time ago, and still wouldn’t show up. In fact, it’s activated right now… Could any other setting be causing the problem?

    srijith.v, thanks for volunteering to check my site. what kind of access do you need? what settings/files do you need to check?

    thanks again!!

    Plugin Contributor Srijith V


    @soret:If you have a dev site, that is preferred. I will need admin access to check plugin/theme files.

    what is a dev site? I’m sorry, I’ve never granted access to anyone. Not that I’m not willing to. It’s just that I’m not sure what you are asking :S

    @srijith.v I don’t see an option to enable “Show on excerpts” under the “Screen Options” drop down menu on that page. Could be more specific and direct me please?

    I’m having a similar problem, currently unresolved but is here:

    In my case, AddThis is not displaying only on pages where a manual eshop shortcode has been added to the page.

    Working page (eshop active but without a shortcode added) =

    Page not working (shortcode in use) =

    AddThis reappears without problem if the shortcode is removed.

    Perhaps this case will assist in working towards a resolution!

    Many thanks

    Hello, friend. It seems that your problem is exactly like mine. I thought the problem was on the plugin that the shortcode was calling to, but it appears that it’s the Addthis buttons that will not show if there is any shortcode in the post/page.

    There is one way to get around this problem, although it is pretty sloppy. What I did was copy the source code of the entire Addthis button container from a post/page that worked, and then pasted it on my post/page that didn’t work (in code view, of course). Doing this, the buttons will appear just as if they were working correctly.

    I hope this helps you, and I hope this problem gets solved soon. When I see two button containers on my web, I will know it is fixed 😉 😉

    Hello friend Soret!! Thank you so much for the reply. It’s great to know that we are not alone in this problem!! 🙂

    I’m not quite sure what you mean by source code in this sense, I tried copying from one page (using Inspect Element in Chrome) but the buttons ended up above each other rather that side-by-side.

    Could you possibly send an example of the code to make sure I’m using the right bit. That would be a great help. You can contact me through if you’d prefer not to post in public.

    Many thanks and best wishes,


    WoOopS! I tried doing it on your website and it didn’t work, so I realized I messed up on my explanation after doing some research. I didn’t exactly do it as I said, so scrap that. Here’s how I did it:

    When you go to “Settings” > “AddThis Share” in your backend panel, you have several options to choose from, on the top and on the bottom. What I did was choose “Custom buttons” for both top and bottom. An empty box will appear for each one, in which you can paste a generated code that you can customize on one of the links shown there, called “ Sharing Tools” (exactly this one). On that page, I chose exactly how I wanted my buttons to show (you can take a look at the “Preview” box). This is pretty cool, because you can add additional buttons that don’t show by default (for instance, google plus). Then, I copied the code from the “Add to your site” box to paste it on the boxes that appeared after clicking on “Custom buttons” earlier.

    Although it may seem tricky, it is the best way to customize the buttons. When you save settings, the button code that you pasted on the boxes will be the one that will show on all of your posts/pages. So, if you paste that exact same code on the posts that can’t show Addthis buttons, it will be as if the Addthis plugin worked 😀 . I, for instance, wanted buttons on the very top and bottom of my posts/page, so I pasted that code twice, one on the very top and another one on the very bottom. Simple, right?

    Yeah, that’s what I meant. Sorry for the confusion 😀

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘AddThis buttons not showing on two specific pages’ is closed to new replies.