WordPress.org

Support

Support » Plugins and Hacks » WP Survey And Quiz Tool » Additional Text not appearing

Additional Text not appearing

  • The “Additional Text” in questions is not appearing in any questions.
    I have simply added text to Additional Text but it is not appearing.
    Do I need to enable anything to use “Additional Text”?
    The result is any empty <p></p>.

Viewing 3 replies - 1 through 3 (of 3 total)
  • [Plugin: WP Survey And Quiz Tool]
    Has anyone had this problem? and solved it?

    Hi, has anyone found a solution to this one yet? I am having the same problem, thanks.

    Found it.

    pages/site/surveysection.php is missing a few line.

    Old (near line 31):

    if ( !empty($_SESSION['wpsqt']['current_message']) && !in_array($questionId,$_SESSION['wpsqt']['required']) ){
    				?></font><?php
    			}
    			?>
    
    			<?php if ( isset($question['image']) ){ ?>
    			<p><?php echo stripslashes($question['image']); ?></p>
    			<?php } ?>

    New:

    if ( !empty($_SESSION['wpsqt']['current_message']) && !in_array($questionId,$_SESSION['wpsqt']['required']) ){
    				?></font><?php
    			}
    
    			if ( !empty($question['add_text']) ){
    			?>
                <p><?php echo nl2br(stripslashes($question['add_text'])); ?></p>
    			<?php } ?>
    
    			<?php if ( isset($question['image']) ){ ?>
    			<p><?php echo stripslashes($question['image']); ?></p>
    			<?php } ?>

    [Moderator Note: Please post code or markup snippets between backticks or use the code button.]

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Additional Text not appearing’ is closed to new replies.
Skip to toolbar