Support » Plugins » Additional Post Meta Tags appear at top of page

  • I have a lot of articles on my site that do not have meta keywords, so until I get around to adding individual sets of keywords for each article, I wanted to add a list of keywords that would appear for all of them in the meta keywords tag. I thought that’s what the Additional Post Meta Tags field was for. Is it? Heh.

    In any case, when I add words to that field, they end up appearing on every post I’ve written, but not in the keywords tag, but instead they actually appear on my site, above all the other content. Guessing that can’t be what is supposed to happen. This is what it looks like when I ‘view source’ for a post:
    <!– all in one seo pack [-1,-1,] –>
    <meta name=”description” content=”The power of position in poker is something that shouldn’t be taken lightly. Position in flop games such as Texas Hold ‘Em and Omaha are especially” />
    online poker, reviews

    The keywords I listed in the field are ‘online poker, reviews’. Anyone know what I need to do to fix this?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Try updating the All in One SEO plugin to the latest.

    I just updated it. Unfortunately, that didn’t solve the problem. Everything happens the same as outlined above.


    First of all thanks a lot for this lovely plugin.
    WordPress is already quite SEO-friendly out-of-the-box but this plugin adds all the functionality that WP is missing.

    On topic; I’m having exact the same issue (I don’t want to call it a problem lol)..
    I have the latest version of your plugin (
    and the latest WP version (2.3.3).

    This is how it looks like on my blog;

    Looking forward to a solution..

    Regards, Prodinho.

    There is a clickable help message under that feature that says “What you enter here will be copied verbatim to your header on post pages”. It’s simply *not* meant for keywords. I don’t recommend putting the same keywords on every post and page, this can harm your site and thus there’s no option for it. Hope that helps.

    I completely missed that you could click on the links to get help. Thanks.

    Thanks for the explanation uberdose.

    I don’t mind having all my keywords on all posts if they aren’t placed on top.

    Is there a possibility of having these keywords displayed on the bottom of every post?

    @prodinho: Why would you want this? Your meta keywords should appear *naturally* in your post content anyway. And as I said the option you used is for everything else but meta keywords. Btw. your meta keywords are way too much.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Additional Post Meta Tags appear at top of page’ is closed to new replies.