Support » Theme: GeneratePress » “Additional” panels appear at foot of page edit area rather than in tool bar

  • FixItDik

    (@fixitdik)


    Hi, our website is using the GeneratePress theme and we have just noticed some strange behaviour when editing a page: the “Additional” metaboxes appear at the foot of the page rather than in the side panel.

    When my colleague mentioned this to me I said that it was not the case for me and they were in the side toolbar but after a little messing around (enabling and disabling them in Preferences>Panels) I did indeed get them to appear at the foot of my page, but I was able to drag them from there and back in to the side panel. However my colleague showed me that on their PC, when they attempted to drag the metaboxes, they behaved like blocks on the page and a horizontal scroll bar appeared on the page rather than letting them drop them on the side panel.

    I told them to do a shift-refresh to make sure they had the latest JavaScript and yet it behaved the same.

    So, foolishly, I did a shift-refresh and indeed my browser is now behaving the same as theirs.

    The problem appears to have been reported a couple of years ago here:

    https://wordpress.org/support/topic/editor-view-move-gps-layout-metabox-to-sidebar/

    but that topic was closed and I assume you addressed it once, but it appears whatever fix you implemented has been undone by someone – help!

    Thanks in anticipation

    Dik

    • This topic was modified 2 months ago by FixItDik.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Leo

    (@leohsiang)

    Hi there,

    Not sure if I fully understand but we haven’t encountered this issue for a long time now.

    What version of the theme are you using?

    Thread Starter FixItDik

    (@fixitdik)

    Hi Leo, sorry for the slow response – the notification went to my spam folder, ho hum.

    So we have version 3.0.4, I don’t appear to be able to attach a screenshot to show you what I mean but I hope it really is a re-occurrence of the same issue that was mentioned in the old topic I linked to (the description was spot on for what I am seeing pretty much).

    I can do a screenshot and share it on DropBox, Google Drive etc then PM you the link if that helps?

    Cheers

    Dik

    Leo

    (@leohsiang)

    The theme itself doesn’t control this type of functionality in the Gutenberg editor unfortunately.

    Can you provide the exact steps to put the tools at the footer?

    Thread Starter FixItDik

    (@fixitdik)

    Sorry Leo, I wasn’t sure if this was Guttenburg or not but the only thing that came up when I searched was this (previously linked) topic and as we also use your theme I had hoped it was something like a clash of JavaScript versions.

    As I can’t now get the panels to appear anywhere else it really is simple: open the page in the editor, click the three dots in the top right (above the page/blocks tabs) and select Preferences and select Panels then turn off and back on the “Additional Panels” (layout, custom fields and Yeost SEO in our case) and as you turn each on it appears at the foot of the page edit main panel.

    As I mentioned earlier, this wasn’t happening for me until I did a shift-refresh while on the edit-page page.

    I hope this helps. I hope to get time to try to reproduce this on a clean install of WP and your theme but have to be honest I’m a bit bogged down at the moment and this isn’t a big issue (my client, a friend, couldn’t find the layout options which caused us to start looking and I found them when she shared her system with me over zoom)

    I hope this helps

    Dik

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.