Support » Plugin: Polylang » Additional Languages Spontaneously go to 404

  • Hi,

    I have a site in English (main language) and in French. It has a main domain name, but there are additional domains that point at subpages within the site via a redirect managed by the web server (Kinsta’s redirect tool).

    Both languages work just fine but every now and then the pages start going to 404.

    Going into the Polylang settings and simply re-saving the URL section without making any changes always fixes it, but a short while later, French will invariably and spontaneously break again and start going to 404. Having to continuously monitor the site and re-save Polylang settings obviously isn’t practical.

    At first I thought it was because of Really Simple SSL, which Kinsta support had installed so that we could force SSL connections without breaking the other redirects. However, I have disabled this plugin and the problem persists. Thinking it’s because of the other domains pointing at sub-pages, I have also added this to wp-config.php:

    define( ‘PLL_CACHE_HOME_URL’, false );

    I’m starting to run out of ideas. Can anyone offer suggestions for troubleshooting?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I have the same problem, every now and then the pages start going to 404 and yes, re-saving the URL section without making any changes always fixes it.

    Do you or someone found a solution or cause for the issue?

    The problem stopped happening for us. I’m not 100% certain why because I tried several things, but I did change the URL modifications settings in Polylang to:

    – The language is set from content = selected
    – Hide URL language for default language = checked
    – Remove /language/ in pretty permalinks to selected.

    If anyone else has found a clearer cause for the issue, I’d love to hear it too.

    the problem still appear from time to time 🙁
    re-save of the settings helps.

    Anybody know what can be done?

    Plugin Author Chouby

    (@chouby)

    Hi,

    Intermittent 404 solved by resaving permalinks settings are generally caused by by a conflict with 3rd party plugins (or theme) refreshing rewrite rules in a wrong way. The difficulty is to find which one. As this is intermittent.

    @chouby What can I do to make sure the ploylang rewrite rules are not getting changed.
    I still have the issue especially after update of some plugins(not polylang) and re-saving polylang settings helps.
    Is there a way to hardcode the rules on server side (I’m using ngix)? Or maybe in theme function.php?

    @chouby Maybe you know what plugin can make problems?

    Hello @alexgav!
    I meet the same problem! after installing the Polylang plugin, all of the my site links show 404 page! do you or somebody find a solution for solving this problem?
    I’m using nginx server, too.

    It looks like the problem was solved (at least for me) few versions ago.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Additional Languages Spontaneously go to 404’ is closed to new replies.