Support » Plugin: Woocommerce Google Feed Manager » additional image link, image library, wrong urls

  • Resolved mmtomm

    (@mmtomm)


    Hi,

    the g:additional_image_link defaults to get the values from image library which returns the images paths from others than featured image.
    I have 2 problems there:
    1) some of my images are not stored with the full url so it returns the links this way:

    <g:additional_image_link>
    /wp-content/uploads/2015/10/image.jpg
    </g:additional_image_link>

    2) (a) some products which are very similar I made out of kind of a duplicate post function and then I just change some text and images. (b) Some of them where made in a test environment with a different subdomain before going live in the real domain.
    For (a) it seems they take some information out of wp_post guid or whatever db-field which are not accurate and then return a image path which belongs to the product I cloned from and does not reflect the right image or (b) the images contains the url to the old testenvironment.
    Those products are displayed correct in the frontend where usualy paths are not taken from the GUID field but in the feed I found many where the url is wrong and/or not belonging to the appropriate product.
    Is this somehow a known issue?
    for the g:image_link I work arround this issue with the ‘combine source field’ option, creating the ‘https://mydomain.com&#8217; first and then with ‘no seperator’ selected the featured image source.

    Thanks for this great plugin again
    Tom

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Auke Jongbloed

    (@aukejomm)

    Good solution for the image link.
    You get the hang of the possibilities of our plugin 🙂

    But i have to stress to keep to the WordPress and Woocommerce guidelines and best practise. There are so many solutions possible that plugin developer can never support al these solutions. Some solutions will make things not better but worse and will make your shopping platform unstable.

    We can not support all solutions and are not the plugin that solves every situation created by “work-arrounds” in WordPress.

    That said our plugin is very powerful and you can alter data from the database like you did for the image issue.

    Best regards,

    AUke.

    Hi Auke,

    I fully understand that not all kind of solutions can be supported but from my point of view it looks more like an wrong db-query because the output of g:additional_image_link differs very much. Sometimes the right images are returned, sometimes the wrong ones and, what I discovered new, sometimes none or even more then are assigned are returned.
    In other words: comparing the feed of some of my products (let’s say men t-shirts) with my frontend like customers would see it. All of the products have additional images assigned, hovering over these I see the coorect url (otherwards they would not have been displayed there), so my black shirt have 3 additional images (of course in black), the feed is returning one black image and two more comming from a totaly different product (actually grey ones from a women t-shirt :), looking at the red shirt (has 3 additional red images) none of them is returned, looking on a woman shirt in black which has 4 additionals assigned, 7 are returned (3 images where removed during setting up the product, 3 new were added instead).
    Actually we’re using the same theme enfold as you do at your site. And I just reporting that as an matter of feedback – and of course because I don’t understand why it behaves like that. My 5-star rating for your plugin will be untouched – I would even give 10 🙂
    If you want me to open my test environment for you again or send you some info out of my database feel free to contact me via my email which you already have.
    The bothering guy from Vienna 😉
    Tom

    Plugin Author Auke Jongbloed

    (@aukejomm)

    You are right Tom it is a db-query thing. We assume that images are stored “the right” way, the wordpress standard way. Plugins, themes can do it in several other way’s like not storing the complete url.

    This is not something your users will see on the front of the website because browsers understand that /somedir/someimage.jpg belongs to an domain and will know it is actualy http://somedomain.de/somedir/someimage.jpg.

    SO if everybody is following coding standards everything would be fine.

    🙂

    AUke

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Tom,

    Just to inform you. I will look at this issue anyway, but it could take some time before I can look into it. When I can solve it you’ll get a patch for it.

    Best regards,
    Michel

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Tom, could you confirm you’re using the free or premium version of our plugin? I might have a solution you want to try out, but before I can give you an update I need to know what version you have.

    Hi Michel,

    I’m using the premium “ecommerce” version 1.6.5!

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Tom,

    Please download the following file:

    https://dl.dropboxusercontent.com/u/3129817/class-feed-master-mmt.zip

    And then unpack the file in it to your ‘wp-content/plugins/wp-product-feed-manager/includes/application” folder.

    Then try again and report back if it helped.

    Hi Michel,

    I did upload it, but now the license manager does not activate the plugin anymore.
    Auke initially added two domains to my license one for my test environment t1.*******off.com and one for production *******off.com

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Tom, I see your license has expired. We will look into it.

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Tom, I reactivated your license so you should be able to login again.

    Hi Michel,

    this is working now!
    Great

    So if I could prefix it now with my domain you’ll be added to my Superheros-List 🙂
    cause the output is:

    <g:additional_image_link>
    /wp-content/uploads/2015/10/image.jpg
    </g:additional_image_link>

    but shoud become:

    <g:additional_image_link>
    https://myDomain.com/wp-content/uploads/2015/10/image.jpg
    </g:additional_image_link>

    Using combined fields like I do for featured images does not work in this case cause it outputs only this:

    <g:additional_image_link>
    https://myDomain.comArray
    </g:additional_image_link>

    As an alternative I tried to repair it in google merchant center with feed rules to prefix it with my domain there but they have an bug so it does not work.

    Anyway
    Thanks a lot for the solution with the wrong images
    Tom

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Strange, at my test site it always outputs url’s including the domain.

    Could you check one thing for me? In your media library, if you open an image that has such an incomplete url, is the URL setting for that image complete or is it also missing the domain?

    As for the combined fields output. That is wrong anyway, so I will have to fix that.

    Michel

    Sorry Michel, I did not explained that thoroughly: all of my media files does not contain the domain by intention. They are all saved with relative url’s only, beginning with /wp-content/…

    Best regards
    Tom

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Ok thanks.

    I know that some users use different domains, so I don’t think its a good idea to automatically add the standard domain name as a prefix. So the best solution is that I fix the combined fields output so you can add the correct domain with the help that option.

    I’ll be back!

    Plugin Contributor Michel Jongbloed

    (@michel-jongbloed)

    Hi Tom,

    Could you please try out the following patch?

    1. Download this file: https://dl.dropboxusercontent.com/u/3129817/class-feed-processor-mmt.zip
    2. Backup the file class-feed-processor.php in your ‘wp-content/plugins/wp-product-feed-manager/includes/application’ folder
    3. Copy the content of the downloaded file in that same folder
    4. Try to make a test feed to check if the combination of featured images and a static field now works correctly

    Please let me know the results!

    Best regards,
    Michel

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘additional image link, image library, wrong urls’ is closed to new replies.