Support » Plugin: Pods - Custom Content Types and Fields » Additional fields are not saved

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Josh Pollock


    Your debug info shows that the save session path is not writable. This is almost always a server setup issue that needs to be resolved by your server admin or hosting provider. To confirm that it is not a Pods issue, you can deactivate Pods and then try the following in the PHP console or in your header.php:

    var_dump( session_save_path()  );
    if ( is_writable(session_save_path() )
    echo 'Writable!';

    If this returns a file directory and Writable! with Pods deactivated please let us know as that would indicate an issue with Pods. If it returns false something needs to be corrected with your server.

    Thanks @josh Pollock for your immediate response

    I found there is an issue with server.

    I will move the files to different server and let you know the status

    Great work Great support

    Thanks again to Pods team

    Plugin Contributor Josh Pollock


    @lakshmananphp I’m glad you found the issue and am happy to help. Please let us know if there is anything else we can do to help.

    Hi @josh Pollock

    I’ve moved files to dream host

    But still the issue is not resolved.

    I don’t think its a server issue

    Please check the debug information below

    Debug Information

    WordPress Version: 3.9.1
    PHP Version: 5.4.20
    MySQL Version: 5.1.56
    Server Software: Apache
    Your User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.137 Safari/537.36
    Session Save Path: /tmp
    Session Save Path Exists: Yes
    Session Save Path Writeable: Yes
    Session Max Lifetime: 1440
    WPDB Prefix: bs_
    WP Multisite Mode: No
    WP Memory Limit: 40M
    Pods Network-Wide Activated: No

    Urgently in need of a solution for this


    Plugin Contributor Josh Pollock


    In your original post you said “When I add a filed, it is not being added.” can you please elaborate on what you mean? Are you getting an error when saving the post? Does the custom field value not show in the post editor after you save?

    I cant add new custom fields to a custom post type.

    When I add fields and click save pods button, I get this message

    Success! Pod saved successfully.

    But the fields are empty in pods edit screen as well as in custom post type add / edit page

    Waiting for the solution.

    Someone please help

    Plugin Contributor Josh Pollock


    Sorry about the delay. Is there anyway you would be willing to allow us to access your site’s backend as admin to see what is going on here? This is very unusual and I’d like to see the symptoms first hand and if possible get this cleared up for you right away.

    If so: You can submit login credentials securely here: or create a new account for

    This issue is marked as resolved. I have the same issue. How did you guys fix it?

    Plugin Contributor Josh Pollock



    It was marked as resolved because I never heard back from the original user. I’m not sure what was going wrong there, but I *suspect* given the low memory usage and budget-basement hosting that the problem was that the save, which is happening via AJAX is timing out or exhausting available memory.

    To test this theory, you should do two things: 1) enable WP_DEBUG. 2) Watch the network section of your console and find the AJAX request that is handling the save, and see if it is successful or not.

    If not, I would recommend increasing the memory allotted to WordPress and/or upgrading your hosting.

    Take care,

    Thanks! Will try that.

    I thought I was having a similar problem but it was because of a misunderstanding of how the various ‘Add Field’ buttons work. Might this be your issue as well?

    When you create a new Pod and go to add a field to it, you’re presented with a form to define the field. There default options shown are:

    • Label
    • Name
    • Description
    • Field Type (Plain Text is selected by default)
    • Options: (Required checkbox, unselected)

    Below that (but aligned with the right side of the form) is a button saying ‘Add Field’.
    Below THAT is another row of headers “Label”, “Name”, “Field Type” and below that, another button named ‘Add Field’.

    It looks like the semantics for the two different ‘Add Field’ buttons are different (it might make sense to rename one of them).

    The one associated with the form is the one that does the work of actually storing/saving the field, and the one below the bottom header line displays a new form for entering another field.

    What I had been doing was, assuming that all the ‘Add Field’ buttons just displayed more blank field forms, filling in the data for the first field and then pressing ‘Save Pod’.

    But since I hadn’t pressed the ‘Add Field’ button associated with my defined field, nothing was saved.

    It’s a bit confusing to have two different types of buttons on the same page that do two different things. Perhaps the one associated with the form (that does the actual saving of the field data) could be named ‘Apply’, or… ‘Save Field’ or something like that. Or find a different term for the one that just creates new blank forms to be filled in.

    (from a UX perspective, it feels wrong to me that I have to explicitly save each field I have filled in AND then save the Pod itself to commit my changes – the inner form button seems superfluous – why wouldn’t ‘Save Pod’ commit all the fields I have defined?)

    May problem ended up to be caused by a conflict with another (home brew) plugin.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Additional fields are not saved’ is closed to new replies.