Support » Plugin: Really Simple SSL » Additional Domain SSL Issue

  • Resolved ellowyn

    (@ellowyn)


    Good morning all,

    So I ended up screwing up everything I had worked for because we decided to change our website name by creating a new domain. Our host is ipage.com, and the original domain is https://www.ell0wyn.com. I JUST purchased a new domain https://www.inkresinandpaint.com. Immediately I had a certificate issue with the new domain, so I went into wp-admin settings and changed the WordPress address and Site Address to the new domain, hoping it would fix it. But of course it didn’t.

    I’ve attempted disabling and re-enabling the ssl plugin but that didn’t help. And I’m getting the “Really Simple SSL has received no response from the webpage” error, and also the “The .htaccess redirect rules that were selected by this plugin failed in the test.” error.
    My hopeful end result is to not use the ell0wyn.com anymore, and solely use inkresinandpaint.com with SSL working. I did the SSL on ell0wyn.com myself and had it perfect, but this change isn’t being so nice. Any help would be appreciated.

    Here is my htaccess file since I’m sure it will be asked about.
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    • This topic was modified 1 month, 1 week ago by  ellowyn.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Mark Wolters

    (@markwolters)

    Hi,

    changing the WordPress address and site address isn’t enough to move a site to a new domain. For the domain to move entirely, the old url has to be replaced by the new url in the entire database. This can be done with a search and replace. There are a lot of different tools that can do this, for example https://github.com/interconnectit/Search-Replace-DB. This allows you to search the database for ell0wyn.com and replace it with inkresinandpaint.com. That should get your site back up and running. We do recommend to create a backup before doing this.

    Alternatively, to quickly restore your site to the ell0wyn.com domain you can look up the ‘home’ and ‘siteurl’ entries in the wp_options table and replace them back to ell0wyn.com. See https://www.hostdime.com/kb/hd/wordpress/change-wordpress-site-url-via-phpmyadmin. The ‘home’ and ‘siteurl’ entries are the only two entries that have changed by updating the WordPress address and site address. Once restored, you could then create a backup and try the search and replace.

    Finally, when the site is running on https://www.inkresinandpaint.com you need to get a valid SSL certificate for that domain. Really Simple SSL is a tool to configure your site for SSL, the plugin is not an SSL certificate itself. We recommend to get an SSL certificate via your hosting provider.

    Let me know if you have any other questions.

    Mark

    • This reply was modified 1 month, 1 week ago by  Mark Wolters.
    • This reply was modified 1 month, 1 week ago by  Mark Wolters.
    • This reply was modified 1 month, 1 week ago by  Mark Wolters.

    So it turns out nothing I did was wrong. I did a live chat with ipage, and they re-enabled ssl on their side, and fixed it immediately.

    Just going to leave this here in the event that someone else with ipage has my issue. Their customer service has always been awesome for me. Instantly connects to chat 24/7 and has never tried to put the problem back on me, as long as it’s actually not my fault.

    And thank you for the response Mark. You responded as I was making this!

    • This reply was modified 1 month, 1 week ago by  ellowyn.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.