WordPress.org

Forums

Adding "www." to my domain name (5 posts)

  1. JoePhilpott
    Member
    Posted 1 year ago #

    Hi

    I have a domain name registered to my hosting server (www.theoriginallifestyle.com) with wordpress installed onto it but each time I try to add "www." to the beginning of the domain name in Settings --> General --> WordPress Address & Site Address but it doesn't work. When I visit the website it says "This website has a redirect loop". Can you help please?

    Thanks

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    If the proper setup is done with host and DNS provider, it would work..that said, do you have any sub-domains? sub.domain.com ? http://www.sub.domain.com may not work. Consult host/DNS provider.

  3. JoePhilpott
    Member
    Posted 1 year ago #

    I don't have any subdomains but could you give me any more information about the host and DNS provider please. I use parallels plesk panel

    Thanks

  4. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Most do not realize this but both //www.site.com and //sub-domain.site.com require specific DNS records. They need to resolve in the DNS system to a specific ip address and a host. Both records (www and sub-domain) require specific settings. Start by contacting your web host, gather info., then if not resolved, contact your DNS provider (they may or may not be the same organization). While you may believe that you do not have a sub running, often one is and a host or DNS provider is providing a redirect. So, we here at the forums are quite unlikely to affect a change, you need to please follow above and contact host/DNS provider.

    You can use these tools to discover the host and DNS provider.
    http://www.whoishostingthis.com/
    http://www.domaintools.com/

  5. WPShowCase
    Inactive
    Posted 1 year ago #

    Have a look at the .htaccess file too and see if there is a rule for www.

Topic Closed

This topic has been closed to new replies.

About this Topic