WordPress.org

Forums

Adding widgets not allowed.... (4 posts)

  1. beanbag
    Member
    Posted 6 years ago #

    I've just installed WP2.6 and I'm in the process of adding dynamic widgets to my side bar.

    Everything works perfect apart from one item. Some widgets are simply not available!

    I've tried everything I know to fix this without any luck whatsoever.

    This is a link to a screenshot showing my problem.

  2. beanbag
    Member
    Posted 6 years ago #

    Anyone?

    I still have this issue and I'm now sure it can be fixed directly within the WP database, however whenever I make any changes to it, I get a PHP error at line 621 on WP-widgets.php.

    Any idea how to make changes to the DB entry directly?

    I have the following DB within "WP_options" entry and I've noticed I have effectively 2 sidebars blocking "sidebar-1" control of the remaining widgets. Even my dashboard is reporting 8 widgets in use when only 2 are being used.

    a:3:{s:12:"wp_dashboard";a:6:{i:0;s:8:"calendar";i:1;s:8:"archives";i:3;s:5:"rss-1";i:4;s:6:"search";i:5;s:5:"pages";i:6;s:4:"meta";}s:9:"sidebar-1";a:0:{}s:13:"array_version";i:3;}

    I've tried even removing the code altogether but this doesn't seem to work.

    Does anyone have any idea what "a, s" or "i" mean within the DB parameters?

    Any help would be massively appreciated!

    BB

  3. beanbag
    Member
    Posted 6 years ago #

    OK! I found a fix on another forum. I'm not sure why the problem happened but I basically pasted the default WP DB code for "WP_Options -> Sidebars_widgets".

    Use the following DB entry to "reset" your sidebar if you have this issue:

    a:1:{s:13:"array_version";i:3;}

    Everything works perfectly now.

    Now if only I could add a title to the search widget!

    BB

  4. pye46
    Member
    Posted 6 years ago #

    Thank you so much, beanbag. I have been looking for this answer too. It was exactly what I needed.

Topic Closed

This topic has been closed to new replies.

About this Topic