Support » Plugins and Hacks » [Resolved] Adding Variations removes Add to Cart Button

[Resolved] Adding Variations removes Add to Cart Button

  • I’m trying to launch a store this week but ran into a BIG issue with the woocommerce plugin.

    After inserting variations, the “Add to Cart” button disappears (http://imgur.com/XEkAZx7), but the button shows up without a problem when there are no variations (http://imgur.com/dEHf5jU). Disabling the stylesheet, the button still does not appear. The button does, however, exist in the source code, but “display:none;” is hard-coded (inline) and that attribute doesn’t seem to toggle once a variation is selected. What could cause this?


Viewing 15 replies - 16 through 30 (of 46 total)
  • Citynode – thanks again. I went back and it uploaded. Before I activate it…I was wondering if you knew the following. If I activate the Wootique, make all the changes, etc. and then decide I can’t figure that theme out and want to go back to my old theme (even though it’s not perfect) can I do that? Or will I lose all the other stuff if I activate the new wootique theme?

    If I can do that, then I will try to make the changes and see if that darn cart will show up on that one item.

    I am so glad you are so helpful.

    It depends on where you make changes, but if you are just sticking to core things like defining products, product categories, etc. then you can go back, sure.

    Things like menus, (custom menus) may be more supported by the Wootique theme than your previous theme (it supports two menu areas automatically, for example … if you change back to a theme that only supports one, the second custom menu won’t be visible.

    Most WordPress problems that can be solved by adopting a theme the supports your concerns, though … you would be better off customizing a parent theme that does support your features, than building support into a theme that doesn’t include it in the first place. (Unless you are or have your own, free-of-cost web developer.)

    citynode – the new theme wootique seems to have fixed the problem I was having with not having the cart for varied products! Thanks.
    Do you have wootique? I can’t seem to figure out why my home and about page are the same page. When I click on pages, I don’t have a home page listed in the list of pages. If I try to add a “home” page, then there are two home pages that show up at the top bar. Is there a page for just wootique that addresses everything and or shows a video on every topic?
    What do you think?

    Yep, I just have a few test stores up so far, and I’m using Wootique for a couple of them.

    I’ll check my settings and see what I can see.

    Oh, one thing you should try is to vary the inventory for All Natural Bath Bombs, and upload a different featured image for each kind … you’ll enjoy seeing those update when you change the selected kind.

    Well, the reason they are the same page is that your menu … must be a custom menu, right? Well, both “About” and “Home” just go to your homepage … the URL they both go to is http://carolinashoresnaturalsoap.com

    So, if you want them to be different pages, you’ll need to either fix the menu to link to a different page, if one exists, or if it doesn’t, you’ll need to create one and then update the menu to link to it.

    There are a few different things about “pages” with Woocommerce, but I don’t think your issue is related to the peculiarities of Woocommerce.

    So you ought to visit your “Appearance -> Menus” and “Pages -> All Pages” and see what’s up there.

    You probably don’t need to check “Woocommerce -> Settings -> Pages” just for reference and to make sure you aren’t about to create a page that is automatically created or maintained by Woocommerce.

    double-clicked the internet!

    @citynode, the theme is custom, written by moi. Switching the theme to TwentyTwelve also fails to fix the problem. This site is for a client and I cannot give any links. It’s also in dev mode so going to the url will bring nothing up but a landing page: http://www.shopg2g.com

    I also tried deactivating all my plugins… no avail.

    I wouldn’t have recommended switching to TwentyTwelve to work out what the problem was, I would have said to switch to the Wootique theme, or Artificer, one of the WooThemes themes that is known to support Woocommerce particularly well.

    That won’t tell you where the problem is, exactly, but it will tell you if the problem is in your theme or in your implementation of Woocommerce.

    If you can’t scrub your devsite clean of any confidential client information, to the point where you can share links, screenshots and settings, it is going to be hard for anyone to help you remotely.

    @citynode I switched to Artificer as you advised and still nothing *sigh*

    I’ll whitelist a proxy IP address and you can get in that way. Here’s the link:

    Let me know if you can figure anything out.

    I can tell you one thing, the “add to cart” button shows up, but only after I select one or another of the tabs on the product page, and yes, right after I try to add it to my cart I get the “Please choose product options…” error message.

    But, this seems to be your custom theme again, so I can’t say much more. I’d have to assume the problem is theme-related, since plenty of people are using the plugin without the same problem.

    I never noticed that the button appears if you click the tabs. That’s really strange to me. Changing the theme to Artificer, the tab trick doesn’t replicate. Still no Add to Cart button.

    Would you say reinstalling the plugin might fix the issue?

    Stranger still is that the tab trick only works when accessing the site through the proxy…

    Very strange! I don’t think reinstalling the plugin would help but why not try it. You aren’t getting any love (success) from anything else.

    Though – my usual approach to this sort of thing is to rebuild a test site from a totally diffferent URL/domain name, to be sure that no detritus of earlier development gets in the way. You’re trying to troubleshoot, after all, so you want to eliminate contamination. So, build up a new WordPress installation, add the Woocommerce plugin, and work your way back from general to specific, leaving styling options for the last. If you can get it working completely, and then you bring in your custom theme and it won’t work, then you have your problem located. If you find that you can replicate the problem earlier than the theme stage, by adding plugins or something else, then you can perhaps rule out your theme as the culprit.

Viewing 15 replies - 16 through 30 (of 46 total)
  • The topic ‘[Resolved] Adding Variations removes Add to Cart Button’ is closed to new replies.