Support » Plugin: Front End PM » Adding Transparency to Colors in Appearance tab

  • I’d like to be able to add transparency to the color options in the Appearance tab (Front End PM->Settings->Appearance). For example, changing #000000 to #00000050 but the UI doesn’t seem to support transparency.

    Adding custom CSS does allow for transparency but I haven’t been able to figure out where several options are defined, to make those changes. Specifically Button Color, Active Button Color, Odd Messages Color and Even Messages Color; I’ve looked through style.css several times and haven’t been able to find anything that changes those colors in my tinkering.

    If someone could point me in the right direction file wise or help me with the syntax for custom CC, I’d appreciate it. Thank you!

    • This topic was modified 3 months, 1 week ago by arnfasta.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Shamim Hasan

    (@shamim51)

    You can use browser developer tools to live edit your css and finally copy your edited css and add in Front End PM > Settings > Appearance.
    For firefox see https://developer.mozilla.org/en-US/docs/Learn/Common_questions/What_are_browser_developer_tools#The_Inspector_DOM_explorer_and_CSS_editor

    Thank you, I was able to use the browser developer tools [F12] in Brave (Chromium) to find and change the button color, active button color. I’m still at a loss for how to change the color of the even-odd messages.

    Using the developer tools, I find the code:

    .fep-odd-even > div:nth-child(odd) {background-color: #0DE935;}
    .fep-odd-even > div:nth-child(even) {background-color: #3a3a3a;}

    I modified the colors so they’d stand out if the change went through. Putting that code into the custom css textbox, saving changes and refreshing the front-facing page still gives me the default colors for both even and odd messages.

    I’m not sure if what other component I’m missing or if there’s some other interaction going on (perhaps it’s something to do with Chromium?)

    Plugin Author Shamim Hasan

    (@shamim51)

    Did you tried using !important ?
    Did you tried clearing all type of caches? eg. Server, browser cache.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.