Support » Plugin: Responsive Posts Carousel » Adding rows messes up width formatting

  • archrime

    (@archrime)


    If have Slides per row set to 3, and if I change the ‘Rows’ setting from 1 to 2 (i.e initializing Grid mode), the width of the whole slider becomes very narrow, and instead of 3 slides per row, now only 2 are shown.

    Is this a known bug? And what is the solution to restore slider to full width, and make slider comply with Slides per Row setting?

    If I make ‘Slides per row’ setting zero, the slider looks almost or less as expected, but the slides are not arranged in a proper grid – if one slide on the top row is taller than the others, the corresponding slide in the row below is pushed out of horizontal alignment, which looks bad. Both rows should be horizontally aligned, with rows spaced to suit the tallest slide.

    Also, not sure if related, but the fonts of post text are altered, and buttons within posts are malformatted

    Also, if I tick the new “Shortcodes/Page Builders” option, all text disappears from beneath each slide. I currently have no shortcodes in posts, but I edit posts for this site in a BoldGrid environment

    • This topic was modified 3 months ago by  archrime.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Rameez Iqbal

    (@rameez_iqbal)

    Hi, when using Rows option, please make sure that the Number of Columns is set to 1.

    Let me know if it fixes this issue

    Regards

    archrime

    (@archrime)

    Hi, thanks for your fast reply!

    Is there no way to specify 3 columns and two rows?

    I tried setting columns to 1, but the result was my site froze (no error message)
    When I set it back to 3, it started working again.

    I have managed to get the result I wanted only by leaving the ‘slides per row’ setting blank, and setting the columns to 3 – and I also had to manually ensure each post was the same length in order for the rows not to go out of alignment on the 2nd row.

    The problem with this workaround approach is also that it does not work well responsively on mobile phone – mobile phone needs rows to be 1, not forced to stay on 2

    • This reply was modified 3 months ago by  archrime.
    Plugin Author Rameez Iqbal

    (@rameez_iqbal)

    I will test it and will add options separately for mobile devices also.

    archrime

    (@archrime)

    Further to above, If I set columns to 1, rows to 2, and slides per row to 3, I only get 2 slides per row, with the 4th slide position each row being blank. Also the last two slides on the carousel are randomly offset below the rest.

    • This reply was modified 3 months ago by  archrime.
    • This reply was modified 3 months ago by  archrime.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.