Support » Plugin: Jetpack by WordPress.com » Adding rel=nofollow to Related Posts

  • Resolved Coptic-Treasures

    (@coptic-treasures)


    Hi,
    Is there a way to add rel=nofollow to the Related Posts links, so search engines don’t cconsider it part of the pages and posts?
    ir this is not necessary with the way Jetpack Related Posts work?
    thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Ryan Cowles

    (@ryancowles)

    Great question! Jetpack’s Related Posts module adds rel=nofollow to its links by default. So you don’t need to update any settings if that’s your desired intent.

    I hope this helps!

    Hi! I don’t understand why nofollow tag is by default! Google answered about that: https://www.seroundtable.com/related-post-blog-links-google-nofollow-21546.html

    My opinion is that Jetpack should offer the possibility in their settings.

    Best regards!
    Rafa Labrador

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    @rafalabrador That default setting may change in the future. You can follow our conversation about this here:
    https://github.com/Automattic/jetpack/issues/3366

    Until then, you can use the following filter to remove the nofollow attribute on your site:
    https://developer.jetpack.com/hooks/jetpack_relatedposts_filter_post_link_rel/

    Thanks for your response Jeremy! I have applied the workaround you named and it works like a charm!

    I have written about that in my blog: https://rafalabrador.com/jetpack-related-posts-elimina-nofollow/ (sorry, in spanish)

    Best regards!

    Hi,
    It’s been almost a year since I wrote this question, and I am still getting the same results.
    I haven’t changed anything in Jetpack settings (so i assume that the rel=nofollow still applies).
    However, Google still shows results from my related posts. I confirmed this via Google Search page, as well as Google Custom Search (CSE) that I have for the site.
    This makes my site look very bad, because:
    1- the related posts change (Jetpack create them dynamically, I believe).
    2- Visitors don’t understand that they have to click on a post and scroll down to the bottom to access another post that they searched for).

    My question is still: how to stop Google from indexing Jetpack related posts and think they are part of the post and page contents?

    Thanks.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic ๐Ÿš€

    I havenโ€™t changed anything in Jetpack settings (so i assume that the rel=nofollow still applies).

    That’s correct. You’d have to use the filter I mentioned earlier to change the default behaviour.

    how to stop Google from indexing Jetpack related posts

    Since those posts are just regular posts like any other on your site, they will always be indexed, whether you use Jetpack and its Related Posts or not. If you want Google not to index some of your posts, you will need to use an SEO plugin to forbid access to some of your posts. Jetpack itself does nothing to stop indexing of specific posts on your site.

    I hope this clarifies things a bit.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Adding rel=nofollow to Related Posts’ is closed to new replies.